Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   New timing belt questions (http://www.wrxtuners.com/forums/f72/new-timing-belt-questions-48449/)

Hoonigan04 04-28-2014 10:54 AM

New timing belt questions
 
I recently purchased an 06 wrx with 82000 miles, the dealer put on a new timing belt, two coil packs and a water pump, on the way home on the highway I downshifted to fourth to pass someone and around 4k it bucked and CEL turned on.. Anyone have any ideas on why this happend!?!

Epictofer 04-28-2014 11:10 AM

you need to have the code checked to find out that the light is on for. Then have someone test test/ check whatever component or system the light is on for. the CEL can come on for hundreds of different things.

Hoonigan04 04-28-2014 11:49 AM

I would have but the light went off the next day

Epictofer 04-28-2014 01:04 PM

I would still take it to a dealer and see if they can pull any history codes out of the ecm. There is no telling what it came on for without looking, and no way to give you any sort of answer either. Any number of things could set the light off under those conditions

brfatal 04-28-2014 02:51 PM

[quote=Hoonigan04;450809]I would have but the light went off the next day[/quote]

Doesn't mean the code is gone. ;)

LW_Black4 04-28-2014 06:17 PM

There are many ways to check for CEL codes, including the Dealer option mentioned above.

There are hand-held devices available at auto parts stores, there are engine tuning devices like the popular COBB AP, and there are big $ diagnostic devices at auto shops.

It might give you some peace of mind if you find out what the code was, if you also get some indication of whether it may reoccur again at the same time.

I'd find a competent mechanic familiar with Subaru performance cars and get them to check it out. You might need maintenance services later, so it'll be of future benefit too.

Hoonigan04 04-29-2014 04:09 PM

The code turned out to be po244

Epictofer 04-29-2014 04:34 PM

I believe that is a wastegate control code or too high boost pressure or something like that. Cobbs website has some simple explanations of it.

boo-key 04-29-2014 06:17 PM

That's an overboost code. Do you have any mod on the car. You might wanna check your wastegate arm.

[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com Free App[/url][/color]

GSMNZ 04-29-2014 06:41 PM

Could be a leak in the hoses going to the wastgate as well.

turmic 04-29-2014 08:33 PM

Are there any other mods on the newly purchased vehicle or is it stock? Plus, like justin said. The idiot light might go away, but it doesn't mean the CEL isn't saved. It sounds like an overboost due to a quick downshift and the ECU got caught off guard. Would still like to know if the rest of the car is modded or stock.

Hoonigan04 04-30-2014 07:34 AM

Car has manual boost controller, turbo back exhaust, tomei or tomel wastegate, intake and sti intercooler

Hoonigan04 04-30-2014 07:35 AM

And thank you for all your replies

GSMNZ 04-30-2014 07:41 AM

sounds like your MBC is set for too much boost

Hoonigan04 04-30-2014 07:57 AM

I'm only making 18psi max then it bucks and engine light comes on


All times are GMT -5. The time now is 08:18 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.