Need help: idiot previous owner - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-26-2004, 02:31 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2004
Location: New York
Posts: 10
RoadRacer is an unknown
Need help: idiot previous owner

I bought a used 2002 WRX from a dealership out of Houston. They said the car was Modified. So i went to look at and all i saw was a short shifter, an air/fuel meter, a blue intake tube, and a hacked airbox. Well after i bought it the day i was supposed to pick it up the guy said the CEL came on and it was a bad O2 sensor. I got it and everything was fine. Then i was going on the onramp to the highway WOT in third and it feels like fuel cut and at that same instant the CL comes back on. ( Oh by the way i had the vehicle shipped to germany for before the CEL came on, i am stationed here) So now it runns like crap in 3rd 4th and 5th, but okay in 1st, and 2nd. I took it to the dealership and he put the code reader up to it (in german) and it said something about the 2nd, and 3rd cylinders not firing right. And it had a code about the boost controller. So i look under the hood and ### before me put a damn MBC on there, AND THERE IS ONLY THE FACTORY BOOST GAUGE. Does anybody have any ideas. The dealership said it could be bad plugs, or something of that nature.
RoadRacer is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-26-2004, 08:19 AM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
Colder plugs may help, but I'd just hook the factory boost controller back up and try it like that. A friend of mine had the same problem with the wastegate when using a MBC. I thought his car was just a fluke.
Cosmo is offline  
post #3 of 7 Old 05-26-2004, 08:38 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2004
Location: New York
Posts: 10
RoadRacer is an unknown
Is there anything for wrx's like the VFAQ
s for DSM's? I need to know where the factory boost controller should go and how to hook it back up. Thanks.
RoadRacer is offline  
post #4 of 7 Old 05-28-2004, 08:16 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2004
Location: New York
Posts: 10
RoadRacer is an unknown
well i turned it down for the time being. It now only hits the first number on the gauge.
RoadRacer is offline  
post #5 of 7 Old 05-28-2004, 04:08 PM
WRXtuners Member
 
Tut4u2's Avatar
 
Join Date: Jun 2003
Location: Virginia
Posts: 1,995
Images: 11
Tut4u2 is an unknown
Send a message via AIM to Tut4u2
The boost selnoid is under that rectangular box above the stock air box. www.scoobymods.com or www.nasioc.com should have more than enough information to help you out.

Che
Tut4u2 is offline  
post #6 of 7 Old 05-28-2004, 04:40 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
Or you can get information here instead of going to NAZIoc.
Cosmo is offline  
post #7 of 7 Old 05-28-2004, 11:16 PM
WRXtuners Member
 
Tut4u2's Avatar
 
Join Date: Jun 2003
Location: Virginia
Posts: 1,995
Images: 11
Tut4u2 is an unknown
Send a message via AIM to Tut4u2
Sorry sorry, just other options, lol.

Che
Tut4u2 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome