mysterious coolant leak PLEASE HELPP! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-04-2013, 03:19 PM
csilber1
Guest
 
Posts: n/a
mysterious coolant leak PLEASE HELPP!

Hey, I have been doing work on my wrx since I got it in 2007, while I have read an uncountable amount of helpful posts this is my first post ever. I couldn't find others specific enough to diagnose my problem.

I have a 2005 WRX stock (I replace everything with OEM parts.) I did timing belt/water pump about 15k miles ago.

While doing a routine oil change i noticed my coolant was low. Then when I took off the skid plate I noticed a bit of coolant pooled up on the passengers side. After farther investigation, I noticed more coolant pooling up just to the left of the alternator. The whole front of the timing belt cover is also soaked! First thing I thought of was the radiator hose that is right there, but when I look where it connects at the hose clamp it doesn't really seem like that could be the source. It seems like the majority of it is behind that. I had a friend rev the engine up to about 4000 RPM while i looked to see any leak but I could not indicate any happening. Does anyone have an idea where this leak might be coming from!? I am not super familiar with the entire coolant cycle and where the leak could be from. I have posted several pictures below of where I can see coolant. Thanks for your help in advance.

http://i1283.photobucket.com/albums/...ps498ae53f.jpg
http://i1283.photobucket.com/albums/...pscbbd36d2.jpg
http://i1283.photobucket.com/albums/...ps06b9d264.jpg
http://i1283.photobucket.com/albums/...psaa82bc92.jpg
 
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome