Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Low boost for no reason (http://www.wrxtuners.com/forums/f72/low-boost-no-reason-39138/)

Fidrat 09-13-2013 07:10 PM

Low boost for no reason
 
Out of the blue my max boost went from .09MPa to .04MPa. Bone stock no tune. I haven't even opened the hood since my last oil change back in MAY or when I adjusted my head lights. last month.

Stock 03 WRX. I did a search and found others with the same problem but they weren't stock and they never say what fixed it.

Brockton 09-13-2013 09:21 PM

Maybe the solenoid is going out? or perhaps you got a boost leak. It not uncommon for hoses to split and cause low boost.

migueleitor 09-14-2013 12:51 PM

Discount the hoses from the bcs and test it.

If ## boost is ok, bsc is bad.

Happened to me in my all turbo car.

[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com Free App[/url][/color]

Fidrat 09-14-2013 08:31 PM

[quote=migueleitor;356202]Discount the hoses from the bcs and test it.

If ## boost is ok, bsc is bad.

Happened to me in my all turbo car.

[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com Free App[/url][/color][/quote]

Discount the hoses? I think you mean "disconnect". bcs? I assume you mean the boost control solenoid? How do you test it? where is it? ##boost? Not a clue what that means. How would I know if it is ok? What is an all turbo car?

texasmr2 09-15-2013 01:56 AM

When in doubt use the KISS method. ;)

Fidrat 09-15-2013 06:28 AM

[quote=texasmr2;356514]When in doubt use the KISS method. ;)[/quote]

What?WTF

boo-key bear 09-15-2013 07:12 AM

I think he's talking about keep it simple stupid. K.i.s.s.

Fidrat 09-15-2013 09:18 AM

[quote=boo-key bear;356562]I think he's talking about keep it simple stupid. K.i.s.s.[/quote]

Ha! And here I thought he was talking about the rock band. There,now that we've bridged the generation gap how 'bout a little help?!Notfunny!

Brockton 09-19-2013 05:20 PM

Try getting a boost leak test done. Dealership might do it, or a performance shop can do one. They will disconnect the hose going to your air intake filter, and hook a coupler with a PSI gauge to it and run air into it, if you have a boost leak the air is going to be escaping from the leak, hopefully you will be able to hear it, if not it may take some feeling around.

If there is no boost leak, you can start looking at the solenoid, this thread might be of interest: [url=http://forums.nasioc.com/forums/showthread.php?t=1327478]How to test boost control solenoid - NASIOC[/url]

pzr2874 09-19-2013 06:52 PM

Use soapy water (dawn in a spray bottle) when running the BLT, helps a ton.

boo-key bear 09-19-2013 07:20 PM

Blt ....mmmmm!

BLAZE2099 09-19-2013 07:48 PM

Boost leak test there buddy;)

Brockton 09-20-2013 06:37 PM

Luckily the boost system in these cars are pretty simple. Try looking under the hood of a twin turbo car, that's a nightmare, atleast the JZ's are.

Fidrat 09-20-2013 08:09 PM

I tried resetting the ECU last Sunday and I took it on the interstate this morning for the 1st time since then. My turbo is hitting full boost now. I don't even know why I tried that. It was just the first thing that popped into my head.

Now my question is...why? Why did my boost cut out? Why did it come back when I reset my ECU?

turmic 09-20-2013 08:28 PM

No CEL? I wonder if the idiot light is not working.


All times are GMT -5. The time now is 12:20 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.