Leaking BOV??? - Page 2 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#16 Old 12-02-2008, 05:28 PM
WRXtuners Member
 
SuBeast's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 731
Images: 3
SuBeast is on thin ice
Garage
Send a message via AIM to SuBeast
Quote:
Originally Posted by TurboRyan View Post
I have the stock bypass valve stashed away some where at my parents house,
If you didn't install the BOV, than why do you have a stock BPV? :eek::eek: Just messing. Are the bolts on the BOV even tightened all the way? Also, do you have a TMIC or a FMIC. It could be that the previous owner didn't tighten it enough or has the wrong adaptor flange. The stock flange as far as i'm concerned doesn't fit the stock WRX's flange. I've got a Turbo XS BOV sitting in my garage and the way it tightens onto the intake piping doesn't seem like a very reliable method....

FAST
RELIABLE
CHEAP
Pick 2
2006 STi
1990 Civic time-attack project
1990 Toyota Hilux - daily
SuBeast is offline  
Sponsored Links
Advertisement
 
#17 Old 12-04-2008, 10:17 PM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
So i just tried adjusting the BOV with some washers, the only thing it did was change the sound it makes and made the idle kinda weird. I don't see how a BOV could cause me to only run 5-7psi and make it cut out like it does. I'm not sure where i should look next, i feel like i have replaced almost every thing but the engine!
I still have the stock TMIC, I took the BOV all the way off, took it apart and put it back on with out any positive results....
TurboRyan is offline  
#18 Old 12-05-2008, 12:16 AM
WRXtuners Member
 
Join Date: Nov 2008
Location: California
Posts: 8
laruffa is an unknown
Send a message via AIM to laruffa
Please put the stock BPV on !!!
laruffa is offline  
#19 Old 12-05-2008, 10:09 AM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
Would a BOV cause this kinda problem? Also if i put the stock bpv in where do i attach my boost gauge line? Its currently running off my BOV.....
TurboRyan is offline  
#20 Old 12-05-2008, 12:03 PM
WRXtuners Member
 
SuBeast's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 731
Images: 3
SuBeast is on thin ice
Garage
Send a message via AIM to SuBeast
Quote:
Originally Posted by TurboRyan View Post
Would a BOV cause this kinda problem? Also if i put the stock bpv in where do i attach my boost gauge line? Its currently running off my BOV.....
a T fitting on a vacuum/boost line.

FAST
RELIABLE
CHEAP
Pick 2
2006 STi
1990 Civic time-attack project
1990 Toyota Hilux - daily
SuBeast is offline  
#21 Old 12-05-2008, 12:10 PM
WRXtuners Member
 
adizzle02's Avatar
 
Join Date: Mar 2007
Location: Utah
Posts: 134
Images: 3
adizzle02 is an unknown
i had a similar problem on my 02 with only building about 7psi and it turned out to be my BCS although i had stock turbo and bpv.

Stage 2
adizzle02 is offline  
#22 Old 12-05-2008, 12:36 PM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
So would putting a MBC fix that??
TurboRyan is offline  
#23 Old 12-05-2008, 03:03 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
No, dont do that at all. Look into a 3 port BCS to replace the stock unit. The stock is only a 2 port and not really that great. You will however need a tune directly following the install of a BCS.

CobbTuning.com - How Subaru’s Factory Boost Control System Works

Sorry to steal from you Turmic (but its only fair, lol). But this article describes the stock system and info about it. Good, helpful info.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#24 Old 12-05-2008, 03:35 PM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
Would it be a good idea for me to get a pdx e-tune right now? I'm thinking that may fix my problems, but i'm not sure. So would it be worth my $150 to get the pdx e-tune OR should i try and fix my boost problem then get the e-tune? (I can't get dyno tuned at this time, its to far to drive and to expensive for my budget..)
TurboRyan is offline  
#25 Old 12-05-2008, 08:12 PM
WRXtuners Member
 
WRX_Fan_0717's Avatar
 
Join Date: Nov 2008
Location: Florida
Posts: 36
WRX_Fan_0717 is an unknown
Quote:
Originally Posted by TurboRyan View Post
So would putting a MBC fix that??
Don't ever say that again.

Quote:
Originally Posted by newtothegame View Post
No, dont do that at all. Look into a 3 port BCS to replace the stock unit. The stock is only a 2 port and not really that great. You will however need a tune directly following the install of a BCS.
Concur, get a GM BCS and make sure not to install it until after you get a map for it loaded. You will overboost like crazy. Also, with a 3 port you can throw away your stupid restrictor pill.
I would honestly get about 6 ft of rubber vacuum hosing from Advanced or somewhere are re-do everything. Might be a pin hole leak from age/dry-rotted or something.

Quote:
Originally Posted by TurboRyan View Post
Would it be a good idea for me to get a pdx e-tune right now? I'm thinking that may fix my problems, but i'm not sure. So would it be worth my $150 to get the pdx e-tune OR should i try and fix my boost problem then get the e-tune? (I can't get dyno tuned at this time, its to far to drive and to expensive for my budget..)
Do you have any CEL? You might be in limp mode if you do.
Will explain the boost issue.

Meth'd, EWG'd, Str8 Cut PPG'd, 20G'd Bug-i, 354awhp and 315tq SAE 5 Corrected 50/50 meth @ 19-20psi.
WRX_Fan_0717 is offline  
#26 Old 12-05-2008, 11:36 PM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
Last saturday i replaced all the vacuum lines along with the stupid restrictor pill... Unfortunatly no CEL's (probably because of the AP tuner.) Tomorrow i plan on replacing the fuel filter and checking my spark plugs... Hope fully that will at least help a little. I'm thinking i will get a PDX e-tune next week...
TurboRyan is offline  
#27 Old 12-07-2008, 09:03 PM
WRXtuners Member
 
WRX_Fan_0717's Avatar
 
Join Date: Nov 2008
Location: Florida
Posts: 36
WRX_Fan_0717 is an unknown
Quote:
Originally Posted by TurboRyan View Post
Last saturday i replaced all the vacuum lines along with the stupid restrictor pill... Unfortunatly no CEL's (probably because of the AP tuner.) Tomorrow i plan on replacing the fuel filter and checking my spark plugs... Hope fully that will at least help a little. I'm thinking i will get a PDX e-tune next week...

Wait wait wait. You need the restrictor pill. The only time you don't need it is when the GMBCS goes on.

Hmmm, oh well. Make sure you specify a map for a aftermarket 3 port.

Meth'd, EWG'd, Str8 Cut PPG'd, 20G'd Bug-i, 354awhp and 315tq SAE 5 Corrected 50/50 meth @ 19-20psi.
WRX_Fan_0717 is offline  
#28 Old 12-08-2008, 11:23 AM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Dang it, i go to work and don't check the forums for a bit and newtothegame steals my links. LOL....it's cool.

I think he replaced the pill and that he didn't eliminate it. If you read his post correctly.
turmic is offline  
#29 Old 12-08-2008, 12:51 PM
WRXtuners Member
 
Join Date: Mar 2008
Location: Oregon
Posts: 53
TurboRyan is an unknown
As of today i have replaced the fuel filter, changed spark plugs and switched to the FP16g normal map. The car is definatly doing a little better, it idles perfect and builds boost (not sure how much, i'm still not willing to go WOT) I have a PDX e-tune on order so when that comes in i hope all my problems will be solved!
TurboRyan is offline  
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On