Knocking Noise - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-14-2014, 03:19 PM Thread Starter
WRXtuners Member
 
H0bb1tM1ndTr1x's Avatar
 
Join Date: Mar 2014
Location: New York
Posts: 13
H0bb1tM1ndTr1x is an unknown
Knocking Noise

On my way to work today my car started making an odd noise that sounded like someone knocking on my roof/dropping an infinite amount of acorns on the roof. Only way to describe it really.

I drive an '02 WRX and have already tried a couple things, my main thought was the spoiler had come loose but I tied it down and still hear it.

So here is the run down:

It sounds like it might be directly above the front seats somewhere. The car still runs exactly as it did yesterday, no warning lights, no other noises, and still takes off like a rocket. The only problem is the noise is quite annoying and it starts its continuous knocking around 35mph. Lower than that and I need to be taking a turn or do some swerving, almost like something in the roof is dangling around.

I plan on checking the windshield seal once I'm out of the office in a couple hours as someone offered a wind theory, which was part of my spoiler theory.

Any thoughts?
H0bb1tM1ndTr1x is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-14-2014, 06:11 PM
WRXtuners Member
 
Join Date: May 2006
Location: Virginia
Posts: 2,380
Images: 9
brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to brfatal is a WRX expert worth listening to
Garage
That's the 1st time I've heard of roof noises. Please keep us updated if you find the cause.
brfatal is offline  
post #3 of 4 Old 05-14-2014, 07:33 PM
WRXtuners Member
 
arcticscythe's Avatar
 
Join Date: Dec 2013
Location: California
Posts: 460
arcticscythe is known to be trustworthy and helpful arcticscythe is known to be trustworthy and helpful
Garage
You may also want to tighten down your crossbars, and if you have a auto dimming mirror check and see if the wire is loose, mine made a light tapping noise when i was going down the 405 so I rubber banded it to the post.

Jason
13 WRX Hatch - Cobb OTS Stage 1
arcticscythe is online now  
post #4 of 4 Old 05-15-2014, 09:15 AM Thread Starter
WRXtuners Member
 
H0bb1tM1ndTr1x's Avatar
 
Join Date: Mar 2014
Location: New York
Posts: 13
H0bb1tM1ndTr1x is an unknown
I found the culprit. Apparently the rubber seal along the windshield was popping up once I got enough wind resistance and was somehow, I blame voodoo, sneaking back into it's little space so I didn't notice it at first.

Simple problems. >.<
H0bb1tM1ndTr1x is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome