Idling issues - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 04-12-2010, 03:11 AM Thread Starter
WRXtuners Member
 
suby_doo's Avatar
 
Join Date: Apr 2008
Location: Texas
Posts: 34
suby_doo is an unknown
Send a message via Yahoo to suby_doo
Idling issues

My car has a hard time keeping idle; some days its fine other days its crap..... i can be driving with partial throttle and it will start to hesitate feels like its choking..... Could it be my TGV delete or the IACV is dirty or bad........
suby_doo is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 04-12-2010, 09:02 AM
WRXtuners Member
 
mfarnham's Avatar
 
Join Date: Sep 2009
Location: Massachusetts
Posts: 403
Images: 3
mfarnham is an unknown
As far as I know, a TGV delete shouldn't cause that kind of problem. No CEL's? No sure what the IACV is, but my first thought would be the spark plugs. How old are they?

Mike
mfarnham is offline  
post #3 of 13 Old 04-12-2010, 09:04 AM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Quote:
Originally Posted by mfarnham View Post
No sure what the IACV is
Cleaning And Reattaching The IACV (Idle Air Control Valve)

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
post #4 of 13 Old 04-12-2010, 09:29 AM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
I suppose my first question would be what mods were done and who tuned the car?

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #5 of 13 Old 04-12-2010, 01:10 PM Thread Starter
WRXtuners Member
 
suby_doo's Avatar
 
Join Date: Apr 2008
Location: Texas
Posts: 34
suby_doo is an unknown
Send a message via Yahoo to suby_doo
IACV IS THE idle air control valve, spark plugs are only a month old put the NGK BKR7EIX in there and car has tbxs tbe, short ram intake crank pulley, intercooler with perrin y-pipe, tbxs bov, tbxs fuel rails, tgv delete on a utec stage 1...... and to add when the idle does go all wack it starts to smell like raw fuel
suby_doo is offline  
post #6 of 13 Old 04-12-2010, 01:54 PM
WRXtuners Member
 
mfarnham's Avatar
 
Join Date: Sep 2009
Location: Massachusetts
Posts: 403
Images: 3
mfarnham is an unknown
Quote:
Originally Posted by suby_doo View Post
car has tbxs tbe, short ram intake crank pulley, intercooler with perrin y-pipe, tbxs bov, tbxs fuel rails, tgv delete on a utec stage 1
That's probably your problem right there; you have all those mods on a simple stage 1 tune. You really should have a custom map with those parts. Also, BOVs are known to cause rough idling/stalling.

Mike
mfarnham is offline  
post #7 of 13 Old 04-12-2010, 03:03 PM Thread Starter
WRXtuners Member
 
suby_doo's Avatar
 
Join Date: Apr 2008
Location: Texas
Posts: 34
suby_doo is an unknown
Send a message via Yahoo to suby_doo
true the only thing i can say is that the car just recently started doing this i have been on that tune with those parts for a good while already and never had problems before..... and to add i took the car to autozone to check the dtc's and i knew about the tgv codes but two new ones came up P1446(fuel tank sensor control valve circuit low) and P1491 (crankcase ventilation blowby function problem.... have no idea how to fix those

Last edited by suby_doo; 04-12-2010 at 05:45 PM.
suby_doo is offline  
post #8 of 13 Old 04-14-2010, 09:43 AM
WRXtuners Member
 
mfarnham's Avatar
 
Join Date: Sep 2009
Location: Massachusetts
Posts: 403
Images: 3
mfarnham is an unknown
No idea how to fix those either. I would take it to your mechanic if possible. The first code sounds like maybe engine wasn't getting enough fuel or something.

Mike
mfarnham is offline  
post #9 of 13 Old 04-14-2010, 12:47 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Quote:
Originally Posted by suby_doo View Post
true the only thing i can say is that the car just recently started doing this i have been on that tune with those parts for a good while already and never had problems before..... and to add i took the car to autozone to check the dtc's and i knew about the tgv codes but two new ones came up P1446(fuel tank sensor control valve circuit low) and P1491 (crankcase ventilation blowby function problem.... have no idea how to fix those
Check the gas cap? How about the vaccum hoses? Sounds like a loose vac line.

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
post #10 of 13 Old 04-14-2010, 12:55 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,980
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
He and I looked for vac leaks and they are all over the place.

Thought he bought new gaskets ??? Nathan ?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #11 of 13 Old 04-14-2010, 01:12 PM Thread Starter
WRXtuners Member
 
suby_doo's Avatar
 
Join Date: Apr 2008
Location: Texas
Posts: 34
suby_doo is an unknown
Send a message via Yahoo to suby_doo
got the new gaskets on the intercooler..... and moved that vacuum hose over like you said but now i got those two codes and it does feel like the car is not recieving enough gas.... and i called gillman subaru and they just gave me the run around they wouldnt let me talk to a mechanic they told me they dont have any subaru technicians but if i wanna bring the car by for a diagnostics and pay 90 bucks for what autozone tells me for free
suby_doo is offline  
post #12 of 13 Old 04-14-2010, 01:27 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,980
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I just helped a friend here last month and it ended up being the fuel filter (which you told me is in the bay ONLY ??)

His was in the tank mounted on the pump. When you say it smells like fuel all over the place it makes me think the pump and filter.

Get that IACV done..... Did you put the fuel rails in ? Where does it smell like fuel the most ?

Ask a mod to combine your 2 posts

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #13 of 13 Old 04-14-2010, 01:49 PM Thread Starter
WRXtuners Member
 
suby_doo's Avatar
 
Join Date: Apr 2008
Location: Texas
Posts: 34
suby_doo is an unknown
Send a message via Yahoo to suby_doo
no someone did the rails for me...... smell comes from the bay not the cabin it just enters the cabin through the vents.....
suby_doo is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome