I think I blew it?! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-09-2008, 01:50 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New Jersey
Posts: 7
Images: 5
Nitram is an unknown
Exclamation I think I blew it?!

Hey guys looking for some help. Took my car out this morning and everything was fine till i got i to about 4000rpms, then it just took a dive like it wanted to stall. Runs great till it shud be making some boost then just takes another dive. Is my turbo blown? I didnt notice any smoke and my boost gauge is still working correctly.
Nitram is offline  
Sponsored Links
Advertisement
 
#2 Old 05-09-2008, 02:07 PM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
Could be a preturbo leak, we'll need your mods, if you've thrown a check engine light (and what it is). If your leaking it could cause the car to studder and/or stall out.

Mike
DTRacing Tuned
Longshot is offline  
#3 Old 05-09-2008, 02:18 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New Jersey
Posts: 7
Images: 5
Nitram is an unknown
Got a Hks hi-power catback, perrin intake, blitz boost controller. I did throw the CEL and it does studder.
Nitram is offline  
#4 Old 05-09-2008, 02:26 PM
WRXtuners Member
 
SuBeast's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 731
Images: 3
SuBeast is on thin ice
Garage
Send a message via AIM to SuBeast
You say that it runs fine without boost so Maybe your boost controller is messing with the system???

FAST
RELIABLE
CHEAP
Pick 2
2006 STi
1990 Civic time-attack project
1990 Toyota Hilux - daily
SuBeast is offline  
#5 Old 05-09-2008, 02:35 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New Jersey
Posts: 7
Images: 5
Nitram is an unknown
Yea it was when i had it out this morning, but i went out 10min ago and started it up and now its studdering, running like shit, and its even smelling weird.
Nitram is offline  
#6 Old 05-09-2008, 03:29 PM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
Check all the vacuum lines going to/from the controller and intake (pre and post MAF). Look for loose connections or tears.

Mike
DTRacing Tuned
Longshot is offline  
#7 Old 05-09-2008, 04:05 PM
WRXtuners Member
 
SuBeast's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 731
Images: 3
SuBeast is on thin ice
Garage
Send a message via AIM to SuBeast
Could be leaking out the intake before the MAF, because without the MAF hooked up, the engine studders and dies....

My guess is something wrong with the vacuum lines like Longshot mentioned, or boost controller is doing something... Most likely a leak somewhere, whether it's in the intake system or exhaust system i can't tell...

FAST
RELIABLE
CHEAP
Pick 2
2006 STi
1990 Civic time-attack project
1990 Toyota Hilux - daily
SuBeast is offline  
#8 Old 05-09-2008, 04:54 PM
WRXtuners Member
 
BC_Girl's Avatar
 
Join Date: Mar 2008
Location: Michigan
Posts: 117
BC_Girl is an unknown
Do you have a down pipe as well as the cat-back? And if so, does it have the wastegate?

Boys will be boys, but girls will be fast !
BC_Girl is offline  
#9 Old 05-09-2008, 05:31 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New Jersey
Posts: 7
Images: 5
Nitram is an unknown
Thanx Longshot n Subeast im gonna check it out now. I did have a dp but had to take it off to get it thru NJ inspection.
Nitram is offline  
#10 Old 05-09-2008, 07:13 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New Jersey
Posts: 7
Images: 5
Nitram is an unknown
Had a hose off the boost controller that was loose and nasty. I cut it and put it back on there nice and tight. Took her out and all seems swell. NO CEL! Thanx 4 all ## help fellas!
Nitram is offline  
#11 Old 05-10-2008, 09:55 PM
WRXtuners Member
 
SuBeast's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 731
Images: 3
SuBeast is on thin ice
Garage
Send a message via AIM to SuBeast
Nice! Glad to hear it's fixed

FAST
RELIABLE
CHEAP
Pick 2
2006 STi
1990 Civic time-attack project
1990 Toyota Hilux - daily
SuBeast is offline  
#12 Old 07-04-2008, 10:46 AM
WRXtuners Member
 
xmoniewrx's Avatar
 
Join Date: Mar 2007
Location: Illinois
Posts: 509
xmoniewrx is an unknown
I think a bann is in order for basebal2008 LOL!
xmoniewrx is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On