I seriously need some help! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-21-2004, 02:57 AM Thread Starter
WRXtuners Member
 
Join Date: Mar 2004
Location: Colorado
Posts: 2
boostjunky is an unknown
I seriously need some help!

I need some help really bad.I just installed a VISHNU unichip piggyback system and also a TURBONETICS manual boost controller and I was boosting 12 lbs but for some reason when I hit around 80MPH or so the car boggs down and I believe it's the fuel cutting off.Has anyone ever experienced this because it is starting to scare me.If you know why or have any suggestions please let me know.It might not be the fuel cutting off but I have no clue if thats not whats happeing to it.
boostjunky is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-02-2004, 01:30 PM
WRXtuners Member
 
Subie Gal's Avatar
 
Join Date: Feb 2003
Location: WA
Posts: 234
Subie Gal is an unknown
probably hitting boost cut....

who tuned the VISHNU setup for you?

Jamie
Subie Gal is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome