How to check MAF - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 03-22-2008, 11:18 PM Thread Starter
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
How to check MAF

i think my MAF sensor is going bad because i can hardly give it any gas and my car bucks so bad but if i hardly press down on the gas it will kinda run, i cleaned the MAF and it still doesnt run any better but does anyone know how to check the MAF like the out put of it or anything with my volt meter thanks alot
VD5505 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 03-23-2008, 02:11 AM
WRXtuners Member
 
Join Date: Dec 2007
Location: California
Posts: 86
"sub"erman is an unknown
Sounds like you might have a throttle position sensor problem too. But to answer your question, you can probably pull a wiring diagram online that will tell you which wire is which, or you can just start probing with your volt meter and you'll find them. You'll have a 12v power supply, a ground, a 5v signal return wire which goes back to the ECU. With the car on you should be able to read a voltage on the reference wire. Play with the throttle a little to see what the voltage does because it will vary with the amount of air flowing through it. If the voltage doesn't move or goes out of range you're gonna want to replace the sensor. If things appear to be within range check for a bad TPS.

Also, have you done any work under the hood lately? Possible vacuum leak from bumping the hoses.
"sub"erman is offline  
post #3 of 11 Old 03-23-2008, 02:14 AM Thread Starter
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
well i cleaned my MAF really good and put new plugs in it and when i go to barly get on it, it will jerk and stuff and i can not rev past 4 grand and it is running really really rich, do you think my computer went out???? i will try the TPS tomorrow
VD5505 is offline  
post #4 of 11 Old 03-23-2008, 02:15 AM Thread Starter
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
oh yea and my CEL lights are a P0301, PO302, PO303, AND PO304
VD5505 is offline  
post #5 of 11 Old 03-23-2008, 02:32 AM
WRXtuners Member
 
Join Date: Dec 2007
Location: California
Posts: 86
"sub"erman is an unknown
Wow, those are misfire codes for all four cylinders. You're not going to find the problem in the MAF or TPS if that's what's coming up. Are you running any kind of EM? What mods do you have?
"sub"erman is offline  
post #6 of 11 Old 03-23-2008, 10:44 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
might be bad coil packs. check to see that their not loose. and try resetting the ecu

rollin on 17's now and they're dirty
baller_v24 is offline  
post #7 of 11 Old 03-23-2008, 11:37 AM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
Did you put the plugs on the coil packs right? the black plug goes on the rear coilpacks and the white plugs into the front ones.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #8 of 11 Old 03-23-2008, 11:53 AM Thread Starter
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
Yea all that is fine i was driving down the Highway and it was running fine then all of a sudden it felt like i hit a wall and wouldnt drive it would just jerk back and forth like no other but if i hardly touched the gas i could drive it, now it wont rev up past 4 grand and right once i get it into boost just like 1 psi it will go way rich like 10.1 and fall on its face, i was heading home from getting a pro tune as well i have a Cobb, and i have had that cobb on there for over a year, thanks for all your help guys
VD5505 is offline  
post #9 of 11 Old 03-23-2008, 12:21 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
then whoever did the tune messed something up.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #10 of 11 Old 03-23-2008, 12:38 PM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
Hell yeah take it back to whoever tuned your car, shit If this happened to me, i would have turned around as soon as the bucking happened.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #11 of 11 Old 03-23-2008, 12:54 PM Thread Starter
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
It happened four hours after my tune driving home from chicago to des moines and when I switch back to my other fuel map it still runs the same. Do you think it could be my computer.
VD5505 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome