help me!! turbo issues.. - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-18-2011, 11:22 PM
WRXtuners Member
 
Join Date: Jun 2011
Location: California
Posts: 3
dannydubbs81 is an unknown
help me!! turbo issues..

hello im a newie in the sti family too keep it simple.. i bought an 2004 sti.. had it for a week and just today i felt the the car became sluggish... the car is stock but has a turbo back exhaust..

when im driving the turbo feels like its not building pressure... the turbine started sounding a bit louder also almost as if it trying a bit harder...

does anyone know what this could be..and any tips on diagnosing this?? any help would be greatly appreciated..
dannydubbs81 is offline  
Sponsored Links
Advertisement
 
#2 Old 06-18-2011, 11:45 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Start with all your connections, make sure you have nothing loose or even off. Could be as simple asa vacuum leak. It could be that your turbo crapped out also. How many miles on the car?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#3 Old 06-19-2011, 10:28 AM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
I know you didn't say it but does it have an aftermarket bov?? If so the piston in it may be stuck open. Had that happen when my car had a bov on it. Lived on a 2 mile dirt road and after a while all the dust caused it to stick. Big loss in power and a really loud air sound....major boost leak.

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#4 Old 06-19-2011, 04:18 PM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 520
AllExtinct is a helpful contributing member
Off-topic, dont you need a tune for a turbo back setup?
Would that cause the power loss if not tuned for it?

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is online now  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On