help i think i have a leak!! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-14-2006, 06:47 PM Thread Starter
WRXtuners Member
 
jsdubya6's Avatar
 
Join Date: Dec 2005
Location: Tennessee
Posts: 15
jsdubya6 is an unknown
Angry help i think i have a leak!!

ok this weekend i installed an upipe and know my boost only gose up to 14.5 to 15 psi and then starts droping tell about 13.5 at wot and it is making a pssshhhhhh noise any sugestions? p.s i have cobb stage 2 and tbe
jsdubya6 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-15-2006, 06:51 PM
WRXtuners Member
 
Join Date: Jun 2004
Location: Massachusetts
Posts: 59
Imprezzive is an unknown
Send a message via AIM to Imprezzive Send a message via Yahoo to Imprezzive
Ive heard stories from WRX owners claiming the same thing and most of them found it to be an exhaust leak in the up pipe causing a loss of boost. some of them doubled up on gaskets were it meets the turbo, they say when the engine flexs at WOT an normal driving it breaks down the gasket and it leaks. Others had an atmospheric BOV that they installed that was dumping the air out. good luck

Im having a problem just like yours with mine just when it happened i installed a FMIC and Headers/uppipe with a TBE all at once. my boost goes up and down at wot over and over and never holds. a Subaru tech near me is gonna look at it at the end of march, he thinks its neither of those problems but the computer sincing an over boosting happening and it decreases everything to get it back to factory. its like driving a car with a dimmer switch on my motor, its sucky!
Imprezzive is offline  
post #3 of 4 Old 03-15-2006, 09:19 PM Thread Starter
WRXtuners Member
 
jsdubya6's Avatar
 
Join Date: Dec 2005
Location: Tennessee
Posts: 15
jsdubya6 is an unknown
thanks for the reply Im going to probably take it all off sometime next week and start over its just a pain in the butt since i spent about 10 hours just trying to get the uppipe on . I didnt have an problems before with just the tbe and the cobb my boost would go to like 15.7 and stay there untill I let off but i dont know people said that a leek in the uppipe sounds like a screaming banshee but it just sounds like alot of air comming out of a small hole but i dont know if thats just the sound of the turbo being amplifiedform the uppipe.
jsdubya6 is offline  
post #4 of 4 Old 03-16-2006, 08:40 PM
WRXtuners Member
 
Join Date: Jun 2004
Location: Massachusetts
Posts: 59
Imprezzive is an unknown
Send a message via AIM to Imprezzive Send a message via Yahoo to Imprezzive
i tryed twice to write you a good explaining reply of a quick way of removing the up pipe but my computer keeps freezing, ill try again tomorrow if your interested sorry
Imprezzive is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On