help with electronic prosport boost gauge... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 01-06-2008, 09:38 PM Thread Starter
Registered User
 
wrecker83's Avatar
 
Join Date: Jun 2004
Location: California
Posts: 155
wrecker83 is an unknown
help with electronic prosport boost gauge...

Ive installed this electronic boost gauge, and have had it for about a month now. its worked fine, up until just last night when i installed my catless downpipe and was performing a test drive. there should be no relation between my boost gauge failing on me, and my install, but im at a loss, and dont know where to start.
-The gauge is completing its normal opening ceremony, and then it just sits at negative whatever.
-when i rev, nothing happens, and when im driving nothing happens.
-Ive checked the electronic boost receiver, and when i unplug it, the boost gauge slowly moves to max boost, and then when i plug the receiver back in, goes back to negative whatever.
-i dont know what would cause my boost gauge to not register how much boost im getting.
any help would be GREATLY appreciated.
-b-
wrecker83 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-06-2008, 09:56 PM
b7g
WRXtuners Member
 
b7g's Avatar
 
Join Date: May 2007
Location: Illinois
Posts: 232
Images: 4
b7g is an unknown
Is there a recet button or a knob on the gauge itself? Plus check the wires of the receiver for disconnected or corroded connection. I have an electric boost gauge( Omori), the only thing i can think of is a ground or other wire dissconnected...
Maybe someone can shed more light on the issue, but this seems like a problem with a receiver/sender.

drive = freedom

Last edited by b7g; 01-07-2008 at 10:44 AM.
b7g is offline  
post #3 of 7 Old 01-06-2008, 10:11 PM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
the sender probally went out, call prosport, they will send you a new one for free

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #4 of 7 Old 01-06-2008, 10:50 PM Thread Starter
Registered User
 
wrecker83's Avatar
 
Join Date: Jun 2004
Location: California
Posts: 155
wrecker83 is an unknown
yea, my first thought was the sender. the gauge itself is receiving power, just not getting a reading on the boost pressure. thanks for the insight. and im glad that prosport will hook up a brand new sender......for FREE! thanks again.
wrecker83 is offline  
post #5 of 7 Old 02-17-2008, 12:32 AM
WRXtuners Member
 
Join Date: Sep 2007
Location: Ohio
Posts: 47
imprezive591 is an unknown
Send a message via AIM to imprezive591
alright another ???, where would one connect the wire, since there is'nt a mechanical boost line, for the gauge. I obviously know the power wires and what not, but where's the best place to connect the sensor wire for reading the boost?
imprezive591 is offline  
post #6 of 7 Old 02-17-2008, 11:07 AM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
i ran my wires inside the firewall and tapped into the ignition switch

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #7 of 7 Old 02-17-2008, 11:22 AM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
Quote:
Originally Posted by nagyhead View Post
the sender probally went out, call prosport, they will send you a new one for free
+1 nagy, i've seen this happen quite a bit from prosport.

Mike
DTRacing Tuned
Longshot is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On