GFB BOV knocking/Rattle - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 02-29-2004, 02:17 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Unhappy GFB BOV knocking/Rattle

Hey guys. My GFB BOV has been on for about a year. For some reason, just this past week, it began to rattle and knock. When I look under the hood as it's running idle, I can see the inside where it normally opens up to release quickly jumping or rattling around. I'm not sure what has suddenly caused this but the noise is loud enough to hear from in the car at idle and out of the car even with the hood closed and doors closed. I removed it and tried to be sure all connections were tight and lubricated but to no avail when I put it back on, same knocking/rattle. Any other suggestions before I take it back to the dealer that put it on for a fix or possible replacement? Thanks.
WizzD is offline  
Sponsored Links
Advertisement
 
#2 Old 03-07-2004, 06:19 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Anyone?
WizzD is offline  
#3 Old 03-07-2004, 09:25 PM
WRXtuners Member
 
Kobiyashi's Avatar
 
Join Date: Feb 2003
Location: North Carolina
Posts: 578
Images: 2
Kobiyashi is more helpful than not
besides that is the valve working properly? I also know you stated you lubed it, did you notice anything cracked or loose?
Kobiyashi is offline  
#4 Old 03-08-2004, 05:07 AM
WRXtuners Member
 
BlueDemon's Avatar
 
Join Date: Apr 2003
Location: Florida
Posts: 1,223
Images: 7
BlueDemon is known to be trustworthy and helpful BlueDemon is known to be trustworthy and helpful
Send a message via AIM to BlueDemon
Normal. Mine does the same thing. So long as it is not functioning irregularly, then I wouldn't be so concerned. It's weird though, as mine used to do it, now has stopped. Just give it a while, or get rid of it, because it's something they seem to do.

Blue
BlueDemon is offline  
#5 Old 03-08-2004, 06:45 AM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
I didn't notice anything cracked or loose when I took it off. It just doesn't seem like a normal thing to me. I see it's happened to some of you as well. I hope it just goes away. If not soon, I'm going to replace it with another.
WizzD is offline  
#6 Old 03-11-2004, 10:44 AM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Well, the rattle/knocking around hasn't gotten' any better to it's gonna' be @ the Subie dealer where it was purchased and installed. Droppin' it off tonight after work and they're gonna' look at it tomorrow. I'll post the details when I get it back.
WizzD is offline  
#7 Old 03-12-2004, 03:46 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Solved!

Well, got the car back and the bypass hose plug was hitting the BOV and causing the rattle. They removed it all, cleaned it, re-adjusted everything and re-installed. All is right with the world again.
WizzD is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On