Fuel/Turbo Issue - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-03-2010, 12:42 PM Thread Starter
WRXtuners Member
 
Join Date: May 2010
Location: Colorado
Posts: 2
utra is an unknown
Fuel/Turbo Issue

I couldn't really find anything similar posted so I'll describe my situation. I have a 2009 Impreza WRX, right about 9.5k miles. It has always ran very well with no issues so far and I just got it serviced/oil changed.

The problem I think started from either accidentally putting in a lower octane fuel or fuel that wasn't premium as it said. I say this because after I filled it, the first 1/4 tank was fine, then I was cruising on the highway and it started reving up the engine. Basically, it feels very week and if I don't coax it along it will rev really high without actually speeding up. It also feels like the turbo isn't doing anything at all once I get into the rev range it normally kicks on.

I am planning on going to the dealership tomorrow but wanted to see if anyone has experience with this.
utra is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-03-2010, 01:01 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Almost sounds like a clutch issue.

-Chris
RcrsWetDream is offline  
post #3 of 3 Old 05-04-2010, 12:03 AM Thread Starter
WRXtuners Member
 
Join Date: May 2010
Location: Colorado
Posts: 2
utra is an unknown
I looked around at some what happened to other peoples 09 wrx's that had clutch issues and some of the symptoms are what I'm having ... time to see what the dealer will do
utra is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome