Fainted "Clanking" Sound? :( - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-17-2008, 01:00 AM Thread Starter
WRXtuners Member
 
Strider327's Avatar
 
Join Date: May 2006
Location: California
Posts: 336
Strider327 is on thin ice
Fainted "Clanking" Sound? :(

Hey everyone, I'm starting to get a slight weird clanking noise. Can't really pinpoint it directly but it seems to coming close to the IC area/intake manifold. Its faint but if listened carefully, you can hear it. Has anyone experienced this before? Hopefully its not a heavy mechanical issue or a serious problem. I have done all major tune-ups, such as Timing belt, spark plugs, all fluids. The only things that I know I haven't replaced are the pulley belt and alternator belt. Any advice what it may be is appreciated. Thanks.

Note: I can hear the noise at idle only as far as I can tell. Its very very faint and even with the hood open its still a very fainted sound.

04 WRX Stage 2 at 47K miles:
Up-pipe/Downpipe
Turbo Inlet
PNP Exhaust manifold/Hi Flow Crosspipe
Accessport V1
Strider327 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome