Extreme Engine Problems... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 11-30-2009, 07:05 AM
WRXtuners Member
 
wfocory's Avatar
 
Join Date: Nov 2009
Location: Idaho
Posts: 3
wfocory is an unknown
Extreme Engine Problems...

So i've been searching for about 3 hours now and I decided to just ask.

So I just finished putting my car back together and even had a subaru tech help me. How ever when I start it, it idles really rough and sounds like its drowning its self. I up'd timing and cut fuel but i still am running way to rich. Also if i get on the gas a little it only builds about 5 psi and maybe revs to 2800rpms and cuts. I can't figure out what my problem is. Please help.
wfocory is offline  
Sponsored Links
Advertisement
 
#2 Old 11-30-2009, 03:36 PM
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
Could be anything, what was done to it? Was the ecu reset? Are the sensor all plugged in etc. Any check engine light? how long have you let it run?

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin
ratfink is offline  
#3 Old 11-30-2009, 07:17 PM
WRXtuners Member
 
wfocory's Avatar
 
Join Date: Nov 2009
Location: Idaho
Posts: 3
wfocory is an unknown
1000cc fuel injectors, 255 fuel pump, port and polished heads, head studs, tactrix tuning cables, front mount

i let it run for about 30 mins

i have cel because i have no o2 sensor
wfocory is offline  
#4 Old 11-30-2009, 07:26 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
No exhaust, no turbo upgrade? Just seems like an odd upgrade path. If you have the tatrix cable have you logged/checked everything out?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#5 Old 11-30-2009, 08:11 PM
WRXtuners Member
 
ratfink's Avatar
 
Join Date: Oct 2008
Location: Idaho
Posts: 518
ratfink is a helpful contributing member
You probably need to ramp down the fuel trim ALLOT with that setup. Did you flash a map set for that kind of flow? Sounds like just a tune issue to me.

Brad

AEM CAI, Perrin ELH wrapped, Catted Downpipe, Stage II XPT tune, K4RT30Y STS, lip, shark fin

Last edited by ratfink; 12-01-2009 at 08:43 AM.
ratfink is offline  
#6 Old 12-01-2009, 12:00 AM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
definitely a tuning issue...if you can post a log I can try and help you out

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
#7 Old 12-01-2009, 12:53 AM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
His profile says a custom TBE and a T70 turbo

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#8 Old 12-01-2009, 07:14 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Quote:
Originally Posted by turmic View Post
His profile says a custom TBE and a T70 turbo
My bad Kirt I realized that after I posted it, but thats a massive turbo for a small 4 cylinder.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#9 Old 12-01-2009, 10:18 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
it certianly is

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#10 Old 12-11-2009, 12:46 PM
WRXtuners Member
 
wfocory's Avatar
 
Join Date: Nov 2009
Location: Idaho
Posts: 3
wfocory is an unknown
We have been data logging for a few weeks now but for some reason its still not running right. I'm sending it to Tommy Motorsports to have them look at it. We turned down the fuel injectors to 500cc on the tune and advanced some timing and opened the maf all the way and some other things. I don't tune my two friends do. Anyways it will run lean like 17's on my airfuel when i barely push the gas where it should be 14's and if I accidently tap the gas to much it wants to flood out. I also found I had some boost leaks and somethings were not connected.


"Every place I take my car and people look under the hood they all ways say, "Look at that ungodly sized turbo! Do you even spool it? I just laugh and say that there is a lot of foreplay."
wfocory is offline  
#11 Old 12-11-2009, 01:08 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
you are running a MAF on this car?? are you tunning this on a dyno at all??
VD5505 is offline  
#12 Old 12-11-2009, 07:06 PM
WRXtuners Member
 
pb-king07's Avatar
 
Join Date: Mar 2008
Location: Washington
Posts: 135
Images: 2
pb-king07 is an unknown
you still did not say what kinda cels it was giving you. are you sure your not off on your timing
pb-king07 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On