Engine struggles to redline - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 07-19-2003, 03:51 PM
WRXtuners Member
 
Join Date: Jul 2003
Location: la mirada, CA
Posts: 2
herb is an unknown
Angry Engine struggles to redline

My 04 wrx works fine all the way up to 5k. After that, the tach would take forever to get to redline. Particularly in 2nd and 3rd gear, once the tach would read at 6k, a rapid *click click click* noise would come from the engine. This is just a thought, but I think it would be my wastegate letting out exhaust. If anyone has had a similar problem, please let me know. By the way, the car is completely stock.
herb is offline  
Sponsored Links
Advertisement
 
#2 Old 07-19-2003, 05:10 PM
WRXtuners Member
 
Tut4u2's Avatar
 
Join Date: Jun 2003
Location: Virginia
Posts: 1,995
Images: 11
Tut4u2 is an unknown
Send a message via AIM to Tut4u2
I would take it back to the dealer if its stock. Let them worry about it.

Ch3

Che
Tut4u2 is offline  
#3 Old 08-06-2003, 11:44 AM
WRXtuners Member
 
Join Date: Aug 2003
Location: Maryland
Posts: 120
Mdchevyguy is an unknown
Send a message via AIM to Mdchevyguy
I agree, take the car back to the dealer. I test drove an 04 and redlined it by accident, and it rolled all the way up the tach fine w/o any hesitation. This is for the 5 speed. If your car has the automatic in it, then it could be a feature in that transmission b/c a lot of automatics will let you get close but will do all they can to stop you from redlining, especially with overdrive on. But get it to the dealer.
Mdchevyguy is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On