Engine Sputtering in Idle - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 07-12-2012, 03:16 PM
WRXtuners Member
 
Join Date: Jul 2012
Location: California
Posts: 8
bhuebs is an unknown
Thumbs down Engine Sputtering in Idle

Hi All,

So My '11 WRX has been sputtering while in idle for the last few months, its almost like its barely about to stall then comes back to life. It doesnt do it all the time either. At first I just thought it was my A/C because that it when I noticed it the most. Today however, on my drive to work it happened a few times with out the air, then bang in the middle of it happening the CLE, TCS, and Cruise came on! LIMP MODE! All I Have done to her is put an Invidia Q300 on. Anyone have any ideas? I have an appointment with the dealership to get it checked out but just though I would ask if anyone has experinced this. thanks for any help!
bhuebs is offline  
Sponsored Links
Advertisement
 
#2 Old 07-12-2012, 06:09 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Did you pull the codes after the CEL and all came on?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#3 Old 07-13-2012, 10:01 AM
WRXtuners Member
 
Join Date: Jul 2012
Location: California
Posts: 8
bhuebs is an unknown
No not yet because I dont have a code reader. Since this never happened until after I installed the exhaust I'm half worried that it was my exhaust that made this happen and the dealor won't cover whatever the problem is.
bhuebs is offline  
#4 Old 07-14-2012, 04:20 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I seriously doubt the catback made a CEL go on. Get the codes read

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#5 Old 07-14-2012, 09:52 PM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,568
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
Autozone and other parts stores read them for you for free.

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
#6 Old 07-15-2012, 09:34 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^what is this forum you speak of?

Bump for codes.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#7 Old 07-17-2012, 11:34 AM
WRXtuners Member
 
Join Date: Jul 2012
Location: California
Posts: 8
bhuebs is an unknown
It was a my engine was misfiring. Back in Jan. I had my CEL come on and and it turned out it was something with a "coldStart issue." When I took it into the dealorship A Subie rep came out and flashed the ECU with a new software update that they were "testing." Since then they have put out an official updated that they loaded onto my comp yesterday so hopefully that fixed it! Thanks for the input everyone!

BTW- Everyone said Autozone reads the code for free? I've gone into the local atuozone here and they told me they dont do that anymore... So im guess by they, the guy ment just that store?
bhuebs is offline  
#8 Old 07-17-2012, 01:38 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
They should ALL read them for free... Just in CA, they won't clear the code.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On