Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Engine rattle? (http://www.wrxtuners.com/forums/f72/engine-rattle-45561/)

justin93m 03-05-2014 06:47 AM

Engine rattle?
 
hello i own an 03 wrx and i have a slight rattle once i let off the gas, its been going on for a week. when i give the car gas it will rattle when the RPMs are going down. any ideas?? its a stock BOV

brfatal 03-05-2014 07:19 AM

Video?

justin93m 03-05-2014 07:31 AM

i cant upload a video, but when the rpms drop it rattles like theres a beebee in there

brfatal 03-05-2014 10:29 PM

Light weight flywheel?

Sub14WRX 03-06-2014 12:35 AM

it could be a number of things. but my guess if its def coming from the block. could be a bearing issue somewhere in there.

justin93m 03-06-2014 08:30 AM

it sounds like its around the turbo/downpipe area? but it doesnt do it extremely loud like i can barley hear it while im driving but if i life the hood and pull the throttle then ill hear it, my performance isnt affected by it still runs good

arewmors 03-06-2014 09:10 AM

Maybe the heat shield around the turbo has loosed up just a little to cause rattle.

justin93m 03-06-2014 09:28 AM

im not too sure the turbo has a heat shield, it was just replaced a few months ago. it kinda sounds like a bolt is loose and rattling around. but id really like to fix it and living in Central PA its hard without a garage hah

arewmors 03-06-2014 09:32 AM

There's nothing covering your turbo? Even if they replaced the turbo they should have reinstalled your heat shield

justin93m 03-06-2014 09:36 AM

it has no turbo blanket or anything, it does sound kinda like a berring rattling around but wouldnt it have some kind of mechanical problem?

arewmors 03-06-2014 11:05 AM

If your turbo was just replaced a few months ago, and the noise is coming from where the turbo is maybe you should take it back to the place that installed the turbo. Was it a new turbo or used?

justin93m 03-06-2014 11:41 AM

it was a used TD04

06_hawk_eye 03-06-2014 03:59 PM

Where are you located in pa? I had a similar noise turned out to be the plug in the aftermarket down pipe where a 02 can go. Just had to tighten the bolt that was in the hole. Could be the heat shield on the up pipe as well


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

justin93m 03-07-2014 07:50 AM

i am located in the Altoona/State college area. and i had a feeling it might be my shield on my up pipe as well

Htown 06-06-2014 03:25 AM

I had that problem too but turn out to be my turboxs bov. It was rattling I add another washer and noise went away.


All times are GMT -5. The time now is 09:04 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.