Engine Knocking!!! NEED HELP ASAP! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 10-21-2009, 12:12 AM
WRXtuners Member
 
OBEE_Racing's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 110
Images: 3
OBEE_Racing is an unknown
Engine Knocking!!! NEED HELP ASAP!

Just tonight was leaving my girlfriend's and i pulled out on this road and gave it some throttle but didnt give it completely everything and full boosted or redlined. but the car started shaking ALOT. First thought i searched through my Accessport and went to engine knocking and it read -2.8 degrees as the knock. I drove it 20 miles home and im not familar with the knock correction tool on Accessport but it drove alot smoother but u would still tell it was knocking and the knock was at either 1.8 or 2.1 from that point on.

ENG. MODS: cold air-intake, perrin TMIC, bov, downpipe, exhaust, with a perrin custom stage 2 tune map with 18psi.

I have a funeral in 8 hours and gotta drive over 300 miles different places tommarow and dont know what to do at all.

thanks
OBEE_Racing is offline  
Sponsored Links
Advertisement
 
#2 Old 10-21-2009, 08:45 AM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
Do Not Drive The Car Till You Get It Looked At!!!!!

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
#3 Old 10-22-2009, 10:32 AM
WRXtuners Member
 
OBEE_Racing's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 110
Images: 3
OBEE_Racing is an unknown
Well I spent all night researching stuff and my engine didnt make any noices? Well I started it up (before I got your message) It took me 4 trys to get it going. Then it ran completly fine? The Engine light, the accessport, codes, everything was clean. Its soooo strange, I still took precautions and didnt take it out of town, Im lookin to rebuild the engine anyhow because I want to get a bigger turbo set up. But yah, I didnt know if anyone had any idea on whats going on with this stuff? My grandma just passed and left behind her new charger for my brother, lucky for me hes only 15, so im gna drive it while I do the engine rebuild.=)
OBEE_Racing is offline  
#4 Old 10-22-2009, 12:33 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
Make sure its bad first before you actually start doing a rebuild. I wouldn't spend the money on a rebuild unless it's actually bad. No telling with those 08's though.

rollin on 17's now and they're dirty
baller_v24 is offline  
#5 Old 10-22-2009, 12:38 PM
WRXtuners Member
 
OBEE_Racing's Avatar
 
Join Date: Aug 2009
Location: Ohio
Posts: 110
Images: 3
OBEE_Racing is an unknown
True. Do you think it would be safe to just replace parts off the engine. pistons, cracks, etc. instead of buying a new block? I wanted to upgrade it anyhow because I want to get a bigger turbo and run higher boost.
OBEE_Racing is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On