electrical problem - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-13-2006, 09:36 PM Thread Starter
WRXtuners Member
 
silver02wrx's Avatar
 
Join Date: Dec 2004
Location: New Jersey
Posts: 89
silver02wrx is an unknown
electrical problem

If u wire gauges to the clock harness does that drain your batter? ### my car has been dying and the mechanic said the battery was slowly being drained ..I have a turbo timer and switches for neons and radar. ?? Any help
silver02wrx is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-13-2006, 09:57 PM
WRXpert
 
bigbadbuddha's Avatar
 
Join Date: Jan 2005
Location: Ontario, Canada
Posts: 1,747
Images: 15
bigbadbuddha is more helpful than not
Send a message via AIM to bigbadbuddha Send a message via MSN to bigbadbuddha
You may have a faulty ground somewhere. Re-chck everything.

Big Jae -
JDM version 7 bugeye
bigbadbuddha is offline  
post #3 of 6 Old 04-14-2006, 04:45 AM
WRXtuners Member
 
joker97's Avatar
 
Join Date: Dec 2005
Location: Australia
Posts: 964
joker97 is an unknown
check the boot light. most cars you can get into the boot via the rear seats that way you keep the boot shut yet can see if there's a light. a very common problem. but with so many other wires in your car you never know. but u must rule out boot light.
joker97 is offline  
post #4 of 6 Old 04-14-2006, 05:37 PM
WRXtuners Member
 
GetUpInDer's Avatar
 
Join Date: Aug 2005
Location: Minnesota
Posts: 178
Images: 2
GetUpInDer is an unknown
Start by doing a draw test and killing power to each one of your mods independently. Which ever one kills the draw is your culprit.
If you have a draw like your mech says it is 99% coming from aftermarket stuff.
GetUpInDer is offline  
post #5 of 6 Old 04-14-2006, 06:23 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Hmm, most likely it isn't a grounding problem. If it was, you would have blown fuses because you have a short. Start with the turbo timer and check if it's draining power while the car is off. If the switches are off, there shouldn't be any issue there unless they are wired incorrectly but then again, if they were wired incorrectly it wouldn't work.

After checking the turbo timer, check the gauges. If the problem is there, change your power source. I suggest the cigarette lighter socket, that's where my neon power comes from. The power to it isn't on if the key is in the off position.
03 CrazyTaxi is offline  
post #6 of 6 Old 04-16-2006, 08:06 AM
WRXtuners Member
 
joker97's Avatar
 
Join Date: Dec 2005
Location: Australia
Posts: 964
joker97 is an unknown
rule out boot light first
joker97 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On