Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Electical and vacuum help please. (http://www.wrxtuners.com/forums/f72/electical-vacuum-help-please-39969/)

STravis 10-03-2013 10:09 AM

Electical and vacuum help please.
 
I bought a 2004 wrx with a fmic, I think an external wastegate, bov, and exhaust. I'm not sure of the whole story on the engine but I think the previous owner swapped some stuff but didn't get everything hooked back up before I bought it. I have a few questions on some electrical plugs and vacuum lines but I can't get any pictures to upload. Can somebody pm me an e-mail address and maybe upload and post the pictures for me?

STravis 10-03-2013 07:27 PM

bump...

boo-key bear 10-03-2013 07:29 PM

I looked at the pix you emailed me but it was hard to see on my phone. Ill look on the laptop and see if I can tell anything.

boo-key bear 10-03-2013 07:34 PM

4 Attachment(s)
Here ya go. Uploaded them for ya.

STravis 10-03-2013 07:35 PM

[quote=boo-key bear;366857]I looked at the pix you emailed me but it was hard to see on my phone. Ill look on the laptop and see if I can tell anything.[/quote]

Ok thanks. If you can post them on this thread I can tell you exactly what questions I have.

boo-key bear 10-03-2013 07:37 PM

I couldn't get the last one to upload but, those electrical connections look kinda like coil connectors or injector connectors.

STravis 10-03-2013 07:40 PM

1st picture: where do all of these vacuum lines go?

2nd picture: what are these two plugs for?

3rd picture: Coil connector.

4th picture: Where do these lines go?

STravis 10-03-2013 07:45 PM

[quote=boo-key bear;366881]I couldn't get the last one to upload but, those electrical connections look kinda like coil connectors or injector connectors.[/quote]

The injectors are all plugged in. The third picture was a coil connector. Thanks.

STravis 10-03-2013 07:54 PM

[url]http://www.wrxtuners.com/forums/members/stravis-albums-engine-problems-picture953-sub5.jpg[/url]

What is this wire. It is spliced into a wire loom on the passenger side frame rail.

STravis 10-03-2013 07:56 PM

[IMG]http://www.wrxtuners.com/forums/members/stravis-albums-engine-problems-picture945-sub4.jpg[/IMG]

What is this connector and where does it go? Passenger side of engine.

boo-key bear 10-03-2013 08:10 PM

[quote=STravis;366913][IMG]http://www.wrxtuners.com/forums/members/stravis-albums-engine-problems-picture945-sub4.jpg[/IMG]

What is this connector and where does it go? Passenger side of engine.[/quote]

That's the pcv connector.

STravis 10-03-2013 08:28 PM

[quote=boo-key bear;366937]That's the pcv connector.[/quote]

How does it need to be hooked up? I can't find any pictures or diagrams.

boo-key bear 10-03-2013 08:35 PM

1st picture...shew! what a mess. Who knows! 2nd picture...Maybe tgv's or there are some connectors on top of the valve cover in that area but, it sure looks like coils or injector plugs. 3rd picture...We figured that one out right? 4th picture looks like pcv or something that goes into your turbo inlet. 5th picture (the one you linked to)...maybe goes to one of those plugs on the passenger side strut tower. Do you have a aftermarket bcs or turbo inlet? if you do I can probably link you to some install instructions that will help you out. Also need to know for sure if you do have ewg. If you do it makes some of the vaccum routing different and I can probably help more if I knew.

BLAZE2099 10-03-2013 08:39 PM

You bought a nightmare.
I'll shout out to some of the more experienced guys on here and see if they can come chime in.

Good luck..... Btw, your belts off;)

STravis 10-03-2013 08:48 PM

[quote=boo-key bear;366985]1st picture...shew! what a mess. Who knows! 2nd picture...Maybe tgv's or there are some connectors on top of the valve cover in that area but, it sure looks like coils or injector plugs. 3rd picture...We figured that one out right? 4th picture looks like pcv or something that goes into your turbo inlet. 5th picture (the one you linked to)...maybe goes to one of those plugs on the passenger side strut tower. Do you have a aftermarket bcs or turbo inlet? if you do I can probably link you to some install instructions that will help you out. Also need to know for sure if you do have ewg. If you do it makes some of the vaccum routing different and I can probably help more if I knew.[/quote]

I'm new to turbo motors and I'm not sure on some of the terms like "tgv" and some of the parts that go along with it but I'm trying to learn. It does have a ewg though and it has a manual boost controller.


All times are GMT -5. The time now is 11:31 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.