downpipe = cel p0420 - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-30-2007, 08:45 PM
WRXtuners Member
 
Join Date: Oct 2006
Location: California
Posts: 24
achavez is an unknown
downpipe = cel p0420

ok ive done the research just want a confirmation on my findings. i intsalled my downpipe 2 weeks ago and i just barely got a cel (p0420). so after research i learned i need a cel fix or i can just drive the car with the cel on right.? my car isnt in limp mode right? thanks for any feedback
achavez is offline  
Sponsored Links
Advertisement
 
#2 Old 08-30-2007, 11:48 PM
WRXpert
 
bigbadbuddha's Avatar
 
Join Date: Jan 2005
Location: Ontario, Canada
Posts: 1,747
Images: 15
bigbadbuddha is more helpful than not
Send a message via AIM to bigbadbuddha Send a message via MSN to bigbadbuddha
I would go out and get the cel fix or better yet some form of EM.... You aren't gonna kill your car but it is always good to do things right

Big Jae -
JDM version 7 bugeye
bigbadbuddha is offline  
#3 Old 08-30-2007, 11:54 PM
WRXtuners Member
 
Join Date: Oct 2006
Location: California
Posts: 24
achavez is an unknown
i forgot to mention i used an xpt map to reflash my ecu.
achavez is offline  
#4 Old 02-28-2008, 12:07 PM
WRXtuners Member
 
ColoWRXer's Avatar
 
Join Date: Aug 2006
Location: Colorado
Posts: 109
ColoWRXer is more helpful than not
a fix is good, an AP is better. it specifically eliminates that code (as well as others) that are caused by tbe. i had my tbe on without EM for probably 12K before the cel went off, then everytime i cleared it it would come back within 50 miles. the AP fixed that and more.
ColoWRXer is offline  
#5 Old 02-28-2008, 12:10 PM
WRXtuners Member
 
Join Date: Jan 2006
Location: Massachusetts
Posts: 68
Images: 2
octoparrot is an unknown
Send a message via AIM to octoparrot
True, but you can do the same with Enginuity / Opensource

OCTOPARROT
octoparrot is offline  
#6 Old 08-30-2008, 12:50 PM
WRXtuners Member
 
bluesubiaz's Avatar
 
Join Date: May 2007
Location: Arizona
Posts: 42
bluesubiaz is an unknown
i put a catlees down pipe on my car and got the same code it a bad o2 sensor so get a new but before you do go on ebay and get a o2 sensor extenstion it pulls the sensor back so the sensor dosent pick up the bad gasses but still gets a reading i did this on my car and im now check engine light free, and the rear o2 sensor is relativly inexpensive un like the front
bluesubiaz is offline  
#7 Old 09-20-2008, 10:19 PM
WRXtuners Member
 
2006wrxturbo's Avatar
 
Join Date: Dec 2006
Location: Virginia
Posts: 23
2006wrxturbo is an unknown
a P0420 code is a catalyst inefficiency code, not a bad o2 sensor.
2006wrxturbo is offline  
#8 Old 09-22-2008, 02:02 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: California
Posts: 102
sfelix818 is more helpful than not
But running a catless 06+ wrx without a good tune or map= Boost creep.
sfelix818 is offline  
#9 Old 09-22-2008, 12:20 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Boost creep can not be tuned out. Only lessened. You either need to change the pill size or get a 3 port BCS to fix the problem. Its a mechanical issue. Just make sure you have it set up correctly and protuned for if you go the BCS route. Changing the pill will not require a protune.

Check out these links:
CobbTuning.com - Service Bulletin: 07 WRX/STi Overboosting with Catless Exhaust

CobbTuning.com - How Subaru’s Factory Boost Control System Works
turmic is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On