Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   cutting out when accelerating (http://www.wrxtuners.com/forums/f72/cutting-out-when-accelerating-32120/)

subaruwrx16 03-01-2012 09:27 PM

cutting out when accelerating
 
i have a 2002 wrx that is all stock except for it is straight piped, but i am planning on gettin a new exhaust soon. so my car runs great with no problems if i am just cruising, but a problem recently came about. When i put the pedal to the floor to do a pull it feels as if i am hitting a governer at about 4500 rps for just a split second, the car cuts out and sort of jerks real fast then it will go back to normal, this happens in 3rd, 4th, and 5th gear... does anybody know what the problem could be and how i can fix it?? any advice would be greatly appreciated !
Thanks, Daymon

bad grocerygetter 03-01-2012 09:42 PM

Is the down pipe stock? If not then there's your problem...it needs a tune on it with that part. Is it throwing a cel? If it is get that code read and let us know what it is. How long has it been doing that?

pzr2874 03-02-2012 05:48 AM

Fuel cut possibly.

Vew 03-02-2012 08:34 AM

Can you reach 4500RPM without flooring it? If you can, and then floor it, does the cut out happen? If yes to both of those, you may have a boost leak somewhere. Check the piping and make sure all your clamps are on tight.

subaruwrx16 03-05-2012 08:59 PM

my downpipe is stock, and it isnt bringing up any CELs. i will try to accelerate slowly and see what happens. i will let you know what i find!! thanks guys

ejs0806 03-11-2012 09:46 PM

check all your houses connected to the turbo and boost control solenoid thing.. Under the little black cover on passanger side near the strut mount. My hoses where cracked and letting turbo go crazy with some boost and im assuming not enough fuel but i had same symptoms it was fine and normal until i put my foot into it

boomerwrx 03-19-2012 09:13 PM

im glad i stumbled upon this thread because my car is doing the same thing

Chris-pee 03-20-2012 01:13 PM

Mine did that for a little while on cold days. After I flashed it with the accessport I noticed it stopped. It would only do it when it was cold out (50 degrees or so and colder) and the engine was cold.

subaruwrx16 06-05-2012 08:37 PM

fixed the problem, having a straight pipe with no cats and a stock downpipe is a bad idea i found out!! the stock downpipes have cats so it restricks the air flow, once the flow was hitting the catless pipe which is not restricted at all it would suck to much air causing it to cutt out. i ended up buying the cobb stage two powerpack and it fixed the problem, the bigger downpipe and the exhaust has the same air restriction and it doesnt cut out anymore!!


All times are GMT -5. The time now is 09:13 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.