Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Cranking really slow on cold start (http://www.wrxtuners.com/forums/f72/cranking-really-slow-cold-start-41090/)

03bugeyeDude 11-06-2013 02:56 PM

Cranking really slow on cold start
 
as title says, car most of the times cranks slowly on cold start but the car does start...
I noticed it happens ever since I moved the battery; I disconnected it to mount it
because it was kind of loose... I made sure everything was well adjusted but
the slow cranking still happens...

the RIOT act 11-06-2013 02:59 PM

Terminals/cables are nice an clean? How old is the battery? Should be stamped on the top or side.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

03bugeyeDude 11-06-2013 03:07 PM

I'd say 3 years old (battery)...

03bugeyeDude 11-06-2013 03:09 PM

I definitely gonna go test the battery, (buy new if I have to) and replace terminals.... just wanted some feedback... thanks

the RIOT act 11-06-2013 03:17 PM

I mean as long a your cables/terminals have a solid connection and the terminals aren't covered in oxidation or corrosion there's no need to replace those.

Could be the battery although 3 years is pretty premature for a battery...


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

BLAZE2099 11-06-2013 03:41 PM

What do you mean by move the battery? Relocate?


All times are GMT -5. The time now is 10:21 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.