CEL mystery - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-26-2008, 03:08 PM
Registered User
 
Join Date: May 2005
Location: Illinois
Posts: 50
blink3020 is an unknown
CEL mystery

My CEL came on about a week ago so I decided to go to autozone and get it checked out. It turns out to be code PO546, which has something to do with the voltage signal from the EGT sensor in bank 1. The car seems to be running fine but I don't want to risk anything. Also, I have had the TB system on for about 10 months now and have not had any problems with it. No CEL or anything.

My current mods are:
Full SRS catless TB exhaust (w/Co2 simulator)
Turbo XS catless UP
Turbo XS BOV
Perrin Lightweight Crank pulley
K&N air filter w/snorkel/silencer removed

I'm sorry if this question has already been asked but I was just looking for some advice/tips. Any help would be much appreciated.

Last edited by blink3020; 05-26-2008 at 04:24 PM.
blink3020 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-27-2008, 06:29 AM
WRXtuners Member
 
Longshot's Avatar
 
Join Date: Aug 2007
Location: Connecticut
Posts: 1,119
Images: 5
Longshot is a helpful contributing member
Send a message via AIM to Longshot
It's because you have a catless UP. Did you remove the EGT sensor entirely? Sounds like you don't have any engine management. I'd look into that right away or your going to get CELs for overboosting rather than just a tripped sensor. Either EM or a mechanical resistor fix will take care of that.

Mike
DTRacing Tuned
Longshot is offline  
#3 Old 05-27-2008, 06:08 PM
WRXtuners Member
 
Join Date: Nov 2005
Location: Virginia
Posts: 66
dak287 is an unknown
do you have a boost guage? does this code come up only when you floor it? ive got an 04 w/catless up without any cells. i would cheak and make sure you dont have boost creep. a mechanical fix may make the light go off but you may have a problem.. might be time for new plugs, fuel filter and maybe some good injector cleaner.
dak287 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On