car will not boost past about 5psi and boggy around 3500rpm - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 02-29-2012, 06:31 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
car will not boost past about 5psi and boggy around 3500rpm

i just bought this car yesterday and went about 500 miles no problems at all. Then today i went to get on it and it sounds like the rev limiter hits at about 3500rpm this happens in 1st gear around 4500rpm. i cant get alot of boost out of it either 4 to 6 pounds max. on the way home when it had no problems it was around 18 psi. i think its a coil or plug i dont know probably something electrical. No check engine light came on either. let me know what you think. THANKS
21latemodel21 is offline  
Sponsored Links
Advertisement
 
#2 Old 02-29-2012, 06:49 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
How many miles on it? If you just bought it I would take it right back to where it was purchased and demand its fixed. Unless you were beating the crap out of, nothing should be remotely wrong with the car.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#3 Old 02-29-2012, 06:55 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
73000 miles bought it kind of long distance from private seller he took extremly good car of the car. and yeah its a new car to me i beat the hell outta it just accelerating fast. also notice on my way home cruising around 80mph hit the gas and it make that noise like when the waste gate hits but makes the noise 3 times. i cant think of what thats called... the checheche noise lol
21latemodel21 is offline  
#4 Old 02-29-2012, 08:05 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Did it just lose all of its boost the next time you turned it on? Or on the way home?

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#5 Old 02-29-2012, 08:06 PM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
Most likely compressor surge is that noise. What kind of mods are done to the car so we may have a place to start helping you. Sounds like maybe the car went to limp mode but with no cel its hard to say.

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#6 Old 02-29-2012, 08:11 PM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,541
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
Garage
I lost my boost twice now since owning mine a little over a year now.
Both times it was due to hitting high psi and blowing my make shift BPV gasket.

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
#7 Old 02-29-2012, 08:35 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
Bc fully adj suspension, Full Invidia g200 exhaust, Invidia bell mouth down pipe, 38mm tial external wastegate,tial bov, turbo xs fmic, aem intake, 255 walbro fuel pump, ngk one step colder plugs,kart boy short throw shifter, aem tru boost gauge, aem wideband a/f gauge,cusco oil catch can, protuned at 18psi, hks turbo timer etc. it just wont boost at all it seems like it takes foreverrrrr to get up to speed compared to what it was like for the short time i had it lol
21latemodel21 is offline  
#8 Old 02-29-2012, 08:39 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
ok ill explain it best i can.. i take off in first 4500rpm it sounds like i hit the rev chip. 2nd gear 3500 rpm rev chip. same until 6th its a turbo hiss and then if i hit the gas a little further is hits the wastegate. and after i was already home from my trip i went to drop my buddy off and it was fine then right when i got to my road all of a sudden it was doing this
21latemodel21 is offline  
#9 Old 02-29-2012, 08:43 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Sounds like a nice Mod list. Is it on the stock turbo still?

Did you do a hard pull to show off to your friend? Sounds like a possible boost leak.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#10 Old 02-29-2012, 08:44 PM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
Honestly I would go over the entire engine bay and make sure no couplers have come off. Check the fmic couplers and anything to do with the boost system...as far as hoses go. Sounds like you have a big boost leak. Or a tuning issue...sorry bud sounds like you may have a tough one to figure out

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.

Last edited by bad grocerygetter; 02-29-2012 at 08:47 PM. Reason: or...
bad grocerygetter is offline  
#11 Old 02-29-2012, 08:49 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
hell yeah i pounded on the car! and i had it up on the hoist at work today and i noticed by the intercooler where the rubber hose connects there was a small crack in it. but it didnt look like it was all the way through. but that much boost would probably open it up? possibly
21latemodel21 is offline  
#12 Old 02-29-2012, 08:56 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Could be the whole way through.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#13 Old 02-29-2012, 09:00 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
its far up though like right before the clamp so its on the metal where hose connects its not in the middle. but even if it was leaking boost would i lose that much power and have a missing sounds still? thats why i thought it may be a coil or maybe plugs? the cars fueling runs really rich and may be fouling out the plugs.
21latemodel21 is offline  
#14 Old 03-01-2012, 05:51 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Quote:
Originally Posted by BLAZE2099 View Post
I lost my boost twice now since owning mine a little over a year now.
Both times it was due to hitting high psi and blowing my make shift BPV gasket.
Shame on you. $8 Randy


$8


OP----------> http://www.turboboostleaktesters.com...WRX-STI/Detail

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#15 Old 03-01-2012, 06:02 PM
WRXtuners Member
 
21latemodel21's Avatar
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 12
Images: 2
21latemodel21 is an unknown
ill try that.. i dont think its a boost leak though it sounds electrical like a coil went bad maybe. or a plug could of the car runs really rich i think it might be easy to foul a plug
21latemodel21 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On