car heater - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-21-2009, 03:29 PM Thread Starter
WRXtuners Member
 
akwrx's Avatar
 
Join Date: Jun 2007
Location: Alaska
Posts: 28
Images: 3
akwrx is an unknown
car heater

I have a 03 wrx, taken good care of it, has 80K miles. The heater isnt working as good as it did last winter. Seems when its at idle its just kicking out cold air but if i give it some more rpm's the heat works. Happens when the car is warm as well, all fluids are fine, just wondering if this is an easy fix. thanks
akwrx is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-22-2009, 05:32 AM
WRXtuners Member
 
EJ Rex's Avatar
 
Join Date: Apr 2006
Location: Alabama
Posts: 86
Images: 6
EJ Rex is a helpful contributing member
Send a message via Yahoo to EJ Rex
Sounds like possibly a thermostat (stuck open), a heater control valve, or water pump (unlikely though).

04 SRR WRX 370whp / 401wtq / EJ205
05 PBM GTO 440whp / 470wtq
http://www.youtube.com/user/EJRex
EJ Rex is offline  
post #3 of 4 Old 10-22-2009, 09:46 AM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,452
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
I agree. Bad thermostat.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
post #4 of 4 Old 10-24-2009, 07:41 PM Thread Starter
WRXtuners Member
 
akwrx's Avatar
 
Join Date: Jun 2007
Location: Alaska
Posts: 28
Images: 3
akwrx is an unknown
ill take a look, thanks!
akwrx is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On