camshaft position sensor problem - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 04-29-2013, 12:28 AM
WRXtuners Member
 
Join Date: Apr 2013
Location: California
Posts: 3
subaruwrx91 is an unknown
camshaft position sensor problem

I recently got a CE light code and it threw me the code P0340 and it says camshaft position sensor A circuit bank 1 or single sensor. I have a 02 Subaru wrx impreza. I recently ordered a new sensor, but I would like to know what the problem could be. Also, I'm having a hard time identifying where the camshaft position sensor is at. Can someone please pinpoint the location for me? Any help will be appreciated. Thanks!
subaruwrx91 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-29-2013, 07:25 AM
WRXtuners Member
 
man show's Avatar
 
Join Date: Apr 2007
Location: Maryland
Posts: 3,095
Images: 2
man show is a WRX expert worth listening to man show is a WRX expert worth listening to man show is a WRX expert worth listening to
I did a quick Google image search, and it appears that the cam position sensor is just above and behind the top cam on the driver's side. I would imagine there's also another sensor in a similar position on the opposite side of the engine as well, but I'm not sure. It doesn't look like it would be terribly difficult to access. Pop your hood and take a look.
Attached Images
 

John
07 WRX (Albins 5MT + Blouch 20G)
Jorge Carrillo Tuned (365 whp/340 wtq)
man show is offline  
#3 Old 04-29-2013, 10:18 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Who's deleting my posts?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On