A/C lines and fan froze on long drive - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-15-2011, 03:08 PM
WRXtuners Member
 
Join Date: Dec 2010
Location: Florida
Posts: 14
m777WRX is an unknown
A/C lines and fan froze on long drive

Yesterday i drove like 3 hrs avg speed about 80mph and i had my a/c on and all of the sudden we noticed that like no air was blowing so we pulled over and i could see that my a/c lines were frozen. so we turned off the a/c and fan and kept driving and about 30 mins later we turned on just the fan and it was working fine. Today i turned on the a/c and that was working fine as well. its an 03 wrx sedan with 125k on it. any ideas why it froze up like that and future ways to prevent or fix it? thanks.
m777WRX is offline  
Sponsored Links
Advertisement
 
#2 Old 08-15-2011, 04:05 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Generally a sign you're low on refrigerant... It'll run for a while but start to freeze up and then not blow... let it defrost for a while and it'll start the freezing up process over again (can take a while to freeze up and stop blowing again).

Probably just needs a recharge.

-Chris
RcrsWetDream is offline  
#3 Old 08-15-2011, 04:07 PM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 555
AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful
Found this on NASIOC for ya.
Hope it helps ya out man.

A/C Freezing up?

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On