Bought 2004 WRX today very confused about power. HELP - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 Old 07-25-2010, 06:36 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
Bought 2004 WRX today very confused about power. HELP

Ok so never owned a subaru before, never even owned a turbo car before. Needless to say I am confused.

Car has sti injectors 556 or somethings, walboro fuel pump, stock turbo just changed back from 18G. Car had front mount now its stock, has a cobb access port turbo timer and boost gauge ACT street/touring clutch, stock exhaust. HKS SSQV.
This is what is happening.
Car seems to hesitate a little from stop going into 1st. Then when you accelerate turbo spools like crazy but no power, car hardly pulls at all, sounds like BOV is leaking.( hks ssqv) shift and at 4000 falls on its face. Has all stock exhaust. every gear no power. You can hear spooling and see a little boost build but around .06 bar it loses all power and the BOV never even goes off. EVER. In 5th absolutely no power and if you downshift the car will spool but fall on it face and barely accelerate.

What the hell is going on?
Give me a check list of stuff to start checking I am so confused.

Thanks
XSellR8nInMyWRX is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 07-25-2010, 06:41 PM
WRXtuners Member
 
Chase's Avatar
 
Join Date: Sep 2007
Location: Washington
Posts: 978
Images: 2
Chase is a WRX expert worth listening to Chase is a WRX expert worth listening to Chase is a WRX expert worth listening to
You probably have a boost/vac leak. Could be where they reconnected the BOV ie, the gasket, or they may not have tightened all the clamps around the intercooler. There's an inlet side on the bottom, and a out side that feeds into the throttle body/intake manifold front and center. I'd take it off. It's easy, 20 minute job if that. See if any of the hoses weren't clamped down tight. Plus with it out of the way, you'll have a clearer view to see other hoses. Just start wiggling stuff around and see if anything is off or loose.

BTW, did you not test drive it first? I've never bought a sport compact without really, REALLY putting my foot into it.

355 awhp fp green six speed wagon in Corvette Atomic Orange
-Brandon
Chase is offline  
post #3 of 21 Old 07-25-2010, 11:15 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
Quote:
Originally Posted by Chase View Post
You probably have a boost/vac leak. Could be where they reconnected the BOV ie, the gasket, or they may not have tightened all the clamps around the intercooler. There's an inlet side on the bottom, and a out side that feeds into the throttle body/intake manifold front and center. I'd take it off. It's easy, 20 minute job if that. See if any of the hoses weren't clamped down tight. Plus with it out of the way, you'll have a clearer view to see other hoses. Just start wiggling stuff around and see if anything is off or loose.

BTW, did you not test drive it first? I've never bought a sport compact without really, REALLY putting my foot into it.
Thank you
for all of your insight. I will look into all of this and repost my results.
And as for the test drive it is very complicated.
XSellR8nInMyWRX is offline  
post #4 of 21 Old 07-25-2010, 11:19 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
While you are at it (checking for leaks) get rid of that crappy BOV. Try and find a stock BPV or look for an aftermekrt BPV. That BOV will do nothing but cause problems also.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #5 of 21 Old 07-25-2010, 11:24 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
It sounds like the boost is leaking right behind the steering wheel when I am driving. Any ideas?
XSellR8nInMyWRX is offline  
post #6 of 21 Old 07-26-2010, 12:16 AM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
Quote:
Originally Posted by newtothegame View Post
While you are at it (checking for leaks) get rid of that crappy BOV. Try and find a stock BPV or look for an aftermekrt BPV. That BOV will do nothing but cause problems also.
what do you recommend?
XSellR8nInMyWRX is offline  
post #7 of 21 Old 07-26-2010, 12:59 AM
WRXtuners Member
 
jdowrx's Avatar
 
Join Date: Jan 2008
Location: California
Posts: 81
Images: 2
jdowrx is an unknown
You should just get the stock bov. You can go on the classifieds on Nasioc and find one for cheap.
Also, I dont know how much of an affect having sti injectors on an otherwise stock wrx would be, but its probably not helping. You said the car came with the accessport, what map are you running?

How does the boost look on your gauge?
jdowrx is offline  
post #8 of 21 Old 07-26-2010, 02:13 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
As far as BPV, like mentioned look for a stock one (I have one, but not in the states to ship it, sorry). Or if you are looking run an aftermarket one look at the Cobb XLE (I run it), the Perrin (I dont really recommend, I had too many issues with it), GFB (go fast bits), Forge, or TurboSmart. All make recirculating (like the stock unit), or hybrids (can be ran like stock, 50/50 (or around that nature) or full atmospheric).

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #9 of 21 Old 07-26-2010, 09:41 AM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
I was told that the cobb was uninstalled. And that it was back to stock.
XSellR8nInMyWRX is offline  
post #10 of 21 Old 07-26-2010, 10:49 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
If the bpv isn't working is there a line from the intake manifold running to the top of the bpv? It's a pretty small vacuum line, but it is the one that actuates the valve.

Mine popped off and I couldn't boost, and my bpv wouldn't go off, causing compressor surge. Took forever to find it as I had to take the top mount off and discovered the line had popped off the intake manifold. It was still plugged into the bpv so it wasn't obvious at all.

-Chris
RcrsWetDream is offline  
post #11 of 21 Old 07-26-2010, 11:25 AM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,499
Images: 7
mosc is a helpful contributing member
Garage
I'd bet he improperly installed the stock turbo and didn't care enough to figure out how.

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is online now  
post #12 of 21 Old 07-26-2010, 11:32 AM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
it's because you are not tuned to be running the STi injectors, put the stock ones in and you'll be fine

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
post #13 of 21 Old 07-26-2010, 02:15 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
Ok so today looked at everything at concluded that the rubber elbow that is hooked to the turbo output is after market and is to big for the stock turbo so I messed with it and tightened up the clamp a bit more. I swapped the BOV for a hks style ebay special that was adjustable. I also added some oil to the BOV rubber gasket to ensure no leakage.
Result the first 3 gears have improved dramatically, but still not right. When you hit 5k rpm it falls on its face. After 60mph NO power at all. If I am in 5th and floor it boost wont hold and wont go past .05 bar. Can only accelerate if I let of the gas which is odd. When boost hits car slows down and will stutter also leads to some black smoke out the back.

I do not have the stock injectors, I would like to upgrade the power, but I wanted to get it right before wasting money on it. I dont want to buy stock injectors if I will need to upgrade later anyway. Can someone advise me on some steps to take.
I need a stock BPV and a stock turbo to intercooler rubber elbow right now.
Thanks

Last edited by XSellR8nInMyWRX; 07-26-2010 at 03:30 PM.
XSellR8nInMyWRX is offline  
post #14 of 21 Old 07-26-2010, 04:05 PM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
get a bloody tune...if you cant find someone you trust I can give you the number of my buddy that goes to UM who tunes his own WRX

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
post #15 of 21 Old 07-26-2010, 04:32 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2010
Location: Maryland
Posts: 9
XSellR8nInMyWRX is an unknown
Quote:
Originally Posted by basco View Post
get a bloody tune...if you cant find someone you trust I can give you the number of my buddy that goes to UM who tunes his own WRX
Sounds great put me in contact with him ASAP thanks I live 1 mile from campus.
XSellR8nInMyWRX is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On