Big problem ! please help ! im desperate - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 03-24-2003, 06:29 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: Ontario
Posts: 79
Images: 1
WRX_Stud is an unknown
Big problem ! please help ! im desperate

Well heres my prob, it just started today as i was driving a friend home i notice that when i shift i hear this rough sqeek and it only happends when i shift up, so far i haven't noticed when i down shift. is this a serious problem ? can i possibly fix this myself, i dont really want to go to the dealer and spend a ton of money on something i could do. Just so you know there are no mods done to this car yet, and after hearing that sound now, i dont know what to do. !Cry! thanks for the help guys/gals
WRX_Stud is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 03-25-2003, 08:22 PM
WRXtuners Member
 
REXronald's Avatar
 
Join Date: Dec 2002
Posts: 603
Images: 12
REXronald is known to be trustworthy and helpful REXronald is known to be trustworthy and helpful
Sounds somewhat familiar...

I have also been hearing a sound when i shift up...
I don't always here it and I wouldn't quite call it a rough squeak... but i also am not quite sure how to explain the sound... I'm guessing that it is something to do with the blow off valve or something.... seem to hear it when i spool up the turbo hard and then don't use all the boost before shifting up... NO clue what it really is or how to fix it... but if you go to the dealer, let me know what they say. How many miles on your car?... about 30k on mine.
REXronald is offline  
post #3 of 10 Old 03-25-2003, 08:26 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: Ontario
Posts: 79
Images: 1
WRX_Stud is an unknown
ive got about just about 20k, but i am going to the dealer within the next week to ask them about the STI suspension so, ill bring up the noise while im there. though im pretty sure its coming from the tranny and not from BOV but i could be wrong, id rather it be the BOV then the tranny ### im gettin a new one anyway hehe ...
WRX_Stud is offline  
post #4 of 10 Old 03-25-2003, 08:33 PM
WRXtuners Member
 
REXronald's Avatar
 
Join Date: Dec 2002
Posts: 603
Images: 12
REXronald is known to be trustworthy and helpful REXronald is known to be trustworthy and helpful
I hear that...

Definitely better to be the BOV then the tranny... tranny work is not cheap... sounds like maybe you've got a different sound than what i am expierencig... Yours definitely a squeaking noise?
REXronald is offline  
post #5 of 10 Old 03-25-2003, 08:37 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: Ontario
Posts: 79
Images: 1
WRX_Stud is an unknown
yeah, actually now to think of it ... it kinda sounds like metal on metal ...!Cry! i also have another clutch and flywheel so if its not the BOV then maybe ill be lucky and itll be one of those two ...
WRX_Stud is offline  
post #6 of 10 Old 03-25-2003, 08:46 PM
WRXtuners Member
 
REXronald's Avatar
 
Join Date: Dec 2002
Posts: 603
Images: 12
REXronald is known to be trustworthy and helpful REXronald is known to be trustworthy and helpful
That's cool...

I'm hoping my little noise is BOV or turbocharger. I have a spare turbocharger that i picked up off ebay... $250 for a turbo with only 2000 miles on it... looks almost new!
REXronald is offline  
post #7 of 10 Old 03-31-2003, 06:38 PM
WRXtuners Member
 
Join Date: Mar 2003
Location: cental ca
Posts: 27
wrxratedII is an unknown
the stock bov makes a loud squel like noise, well not loud but def notacible from inside specialy when the windows are rolled up, if you raise the boost it gets louder. When i modified my stock bov it got about 20% louder. Try letting off the gas real slow when you upshift if the noise goes away, its just the bov doing its job!
wrxratedII is offline  
post #8 of 10 Old 04-04-2003, 05:03 PM
WRXtuners Member
 
Join Date: Apr 2003
Location: Oregon Coast
Posts: 31
SinweaP is an unknown
if it squeaks on take off and up shift only at the engagment point only than it is the pressure plate and clutch more than likely. My pick-up did that before i got rid of it and it was the clutch.
SinweaP is offline  
post #9 of 10 Old 04-04-2003, 11:56 PM
WRXtuners Member
 
Join Date: Mar 2003
Location: cental ca
Posts: 27
wrxratedII is an unknown
if you let the clutch out at idle slowly do you hear it? or only when you give it gas when you let out the clutch, how many miles on the car?
the clutch is warranty for 12k miles only.
wrxratedII is offline  
post #10 of 10 Old 04-05-2003, 02:29 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2003
Location: Ontario
Posts: 79
Images: 1
WRX_Stud is an unknown
when i let it out on idle i dont hear it at all, only when im givin it gas ill hear it. my car has about 20,000 on it so ... im kinda screwed if its the clutch, but i have a replacement for it .. tho i didnt think it would go out that fast ...
WRX_Stud is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On