Bad Leaking Injector After motor Install - Page 2 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#16 Old 03-09-2011, 10:53 AM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
No, one sensor and one motor on each TGV.

Homebrewed tuned with Opensource!
dumdum is offline  
Sponsored Links
Advertisement
 
#17 Old 03-09-2011, 02:12 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Quote:
Originally Posted by Phatnucca View Post
one sensor in the front and one in the back correct? And driver side for sure? Ok i'll check
Dumdum's answer is correct. With your CEL bank 2 error indicating you need to check the driver's side TGV position sensor.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#18 Old 03-09-2011, 06:53 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
Yea i checked. its plugged in, but apparently not working the the butterflies are stuck closed on that side. Anything under 4K rpms pulls normal.. andything about that just feels and sounds like its getting a ton on fuel... yet not enough air.

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#19 Old 03-10-2011, 05:36 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I bet you have to reset the TGV "motors". Has anyone played with them, ie... unscrewed them?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#20 Old 03-10-2011, 03:48 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
idk if that will do anything if the sensor itself is bad. If that motor is not functioning then that means the tgv on that side will not open correct? And those 2 cylinders driver side will not be getting enough air? Thats what it seems like it going on. I was thinking about just taking the butterflies out. idk..

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#21 Old 03-11-2011, 06:00 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Correct... Assuming all years TGV motors are the same, I can get a new one to you. PM me if you like. But below is the delete.

Here ya go :

Results for TGV Deletes

Depends which one you have

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#22 Old 03-12-2011, 11:52 AM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
Well, does anyone know at all that if the bank 2 TGV motor is in fact not working and the butterflies are stuck shut it will fall on its face at about 4K rpm's? Sounds like its just getting a ton of fuel and no air to those 2 cylinders. If those 2 butterflies are stuck shut would it make it run like that

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#23 Old 03-12-2011, 01:13 PM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Quote:
Originally Posted by Phatnucca View Post
Well, does anyone know at all that if the bank 2 TGV motor is in fact not working and the butterflies are stuck shut it will fall on its face at about 4K rpm's? Sounds like its just getting a ton of fuel and no air to those 2 cylinders. If those 2 butterflies are stuck shut would it make it run like that
Uhh..what do you think? I would say yes..........

Homebrewed tuned with Opensource!
dumdum is offline  
#24 Old 03-30-2012, 02:46 PM
WRXtuners Member
 
Join Date: Mar 2012
Location: New Jersey
Posts: 2
STI379 is an unknown
I am having the same problem.
P2021 - It says intake manifold runner position sensor low circuit - bank 2
Now i have been so looking into it that i know a lot about it except when it says bank 2 i know it's driver side - now there is front and rear - the front sensor can't be sold separately according to the dealer and the one in the rear is separate. So which one has to be changed - if any body knows - help would be appreciated. The front is a piece of the intake manifold and costs 400 - the rear like 170 something like that.
Checked all the wiring and everything but this code is gonna kill me. Thanks for any help R.
STI379 is offline  
#25 Old 04-02-2012, 06:29 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^Is it falling on it's face at 4-5K?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#26 Old 04-03-2012, 05:59 PM
WRXtuners Member
 
Join Date: Mar 2012
Location: New Jersey
Posts: 2
STI379 is an unknown
Quote:
Originally Posted by pzr2874 View Post
^Is it falling on it's face at 4-5K?
No it's not.
Today i took the rear sensor out and checked and it's working fine.
So now i am assuming it's the front sensor. Lucky me.
STI379 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On