Bad Leaking Injector After motor Install - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 03-05-2011, 04:42 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
Bad Leaking Injector After motor Install

So i just got my car back from getting a motor put in. Blew the original motor due to bad cam postion sensor over-advancing my timing making me run lean and hot in cylinder 4. Car uns good for the most part, but i was noticing on the drive home a strong gas odor. And also car runs perfectly fine at idle to about 1/2 throttle. After that it falls on its face. I got home left in running and noticed a puddle unbder the car. I popped the hood only to find the front injector passenger side spiutting out gas. Its pretty bad. Might be an O-ring or cracked injector. Either way it is getting replaced tomorrow.

How long should it take to swap out one injector on the passenger side? And also.. do you think the really bad leaking injector would cause it to kinda break up and not want to rev past 1/2 throttle and higher rpm's? I'm thinking so because that cylinder is not getting the propper amount of fuel needed when i step on it.

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
Sponsored Links
Advertisement
 
#2 Old 03-05-2011, 06:14 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Yeah the injector is most likely at fault there. Shouldn't take more than an hour or two for an amateur to swap the injector out.

-Chris
RcrsWetDream is offline  
#3 Old 03-06-2011, 09:35 AM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
Well, got the injector swapped out in an hour. No more leaks. However, i still have the same problem with breaking up extremely bad wot or close to it. And the CEL is still on with the flashing cruise control. Anything part throttle feels normal and has proper power and smooth accel. Also, the idle is fine and there is no missfire at idle or part throttle. Just when u try to get on it it breaks up really bad.. you hear it in the exhaust and dont wanna rev. I guess i'll go to autozone today and have them run the code to see why the CEL is on with flashing cruise. Any ideas?

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#4 Old 03-06-2011, 10:04 AM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Misfire.

Homebrewed tuned with Opensource!
dumdum is offline  
#5 Old 03-06-2011, 12:02 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
Flashing cruise indicates limp mode. That could be due to stored codes before you swapped the injector. Did you clear the ECU after replacing it ?
wagonracer is online now  
#6 Old 03-06-2011, 04:57 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
No.. just disconnected the battery. You think may be plugs? And actually... if i go close to WOT anything under 4K rpms it pulls smooth. soon as it gets to like 4K it starts doing it. maybe new plugs and gapped correctly? I'm at a loss

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#7 Old 03-06-2011, 07:41 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
Clear the codes, drive, then get it scanned and post what codes it's throwing.
wagonracer is online now  
#8 Old 03-06-2011, 08:07 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
got a scanner. ran the codes and its saying intake manifold runner sensor. I erased it but it didnt go away. was on as soon as i started it. even though it said it erased it. I think that when the motor got put in maybe he didnt plug one of the manifold sensors in. I think that would be the only reason it would be on right away. and not take a little while to come back on. I know that if its not plugged in it will be on right away. Where is that sensor at? and which side is bank 2? Thats what it said bank 2

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#9 Old 03-06-2011, 08:36 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
What's the code (number) ?
wagonracer is online now  
#10 Old 03-06-2011, 08:45 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
This list should give you an idea of why you need to be specific

P2004 Intake Manifold Runner Control
Stuck Open (Bank 1)
>
P2005 Intake Manifold Runner Control
Stuck Open (Bank 2)

P2006 Intake Manifold Runner Control
Stuck Closed (Bank 1)

P2007 Intake Manifold Runner Control
Stuck Closed (Bank 2)

P2008 Intake Manifold Runner Control Circuit
/ Open (Bank 1)

P2009 Intake Manifold Runner Control Circuit
Low (Bank 1)

P2011 Intake Manifold Runner Control Circuit
/ Open (Bank 2)

P2012 Intake Manifold Runner Control Circuit
Low (Bank 2)

P2016 Intake Manifold Runner Position Sensor
/ Switch Circuit Low (Bank 1)

P2017 Intake Manifold Runner Position Sensor
/ Switch Circuit High (Bank 1)

P2021 Intake Manifold Runner Position Sensor
/ Switch Circuit Low (Bank 2)

P2022 Intake Manifold Runner Position Sensor
wagonracer is online now  
#11 Old 03-07-2011, 04:03 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
Hey its the 2021 Code. Bank 2 runner postion sensor low circuit

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
#12 Old 03-07-2011, 06:48 PM
 
wagonracer's Avatar
 
Join Date: Jul 2006
Location: Connecticut
Posts: 1,301
Images: 9
wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to wagonracer is a WRX expert worth listening to
That code is pointing to the tumble generator valve position sensor. I would start by checking to make sure they're all plugged in. They are on either end of your intake plenum (manifold)

I forget what bank 2 means. Anybody know ? You can find the entire diagnostic procedure at Impreza Manuals | ken-gilbert.com. Click on and download the 06 impreza manual. It's all in there, including where to locate them exactly in the folder called H4DOTC Engine.
wagonracer is online now  
#13 Old 03-07-2011, 09:39 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Well cyl 1 & 3 are the passenger side so I'd think that is bank one, and bank two is the driver side.

Not positive but pretty sure.

-Chris
RcrsWetDream is offline  
#14 Old 03-08-2011, 05:47 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,973
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^^ That is correct.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
#15 Old 03-08-2011, 03:58 PM
WRXtuners Member
 
Join Date: Jul 2008
Location: New Jersey
Posts: 45
Phatnucca is an unknown
Send a message via AIM to Phatnucca
one sensor in the front and one in the back correct? And driver side for sure? Ok i'll check

07 WRX TR-12.7@106
Invidia Catless DP,Invidia Catback,SPT Intake,Stage2Protuned,Large TMIC
Phatnucca is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On