Annoying clutch pedal creak... Help!!! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-15-2012, 01:36 AM Thread Starter
WRXtuners Member
 
huschkem3's Avatar
 
Join Date: Jul 2012
Location: Arizona
Posts: 22
huschkem3 is an unknown
Annoying clutch pedal creak... Help!!!

for a few months i have been experiencing an annoying creaking noise when pushing the clutch pedal on my 08 wrx. there doesn't seem to be any loss of performance and the clutch seems to be performing fine. i just can't figure out what is causing the creaking noise and what i can do to fix the issue. it is a nuisance and i am concerned that it may be a precursor to something more serious. i am the only person to own this car and it has about 80k miles on it (outside of warranty). has anyone else had a similar problem, if so, how did you fix it?

thank you!!!

paul h - SSFD (super slow 4-door)
huschkem3 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-15-2012, 06:51 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,979
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Is it all the time or just when it's "cold" ?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #3 of 3 Old 10-15-2012, 09:40 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Mine does it, especially when cold.... All I can do is spray liberal amounts of lube up towards the pivot and it seems to help. There's still always a bit of a squeak though.

-Chris
RcrsWetDream is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome