Alternator ? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-01-2009, 05:42 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2009
Location: New York
Posts: 110
Images: 3
slo2sixty is an unknown
Alternator ?

I had my batt tested and its good. The voltage is good most of the time with no problems. As soon as i turn the heat or ac on it drops from 13.7-13.9 to a low of 12! and it will drop sometimes coming to a stop after the clutch is in and the rpms settle. I believe dumdum said the sti/forester alt will fit and have a better output. But what year will fit my 02??? any other suggestions would be great. Thx everyone

02 WRX Now STG 3
92 Ninja 600
Quit crying and be happy. could be driving a mustang - Jujutsuka
slo2sixty is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-03-2009, 12:13 AM
WRXtuners Member
 
pb-king07's Avatar
 
Join Date: Mar 2008
Location: Washington
Posts: 135
Images: 2
pb-king07 is an unknown
look at all your grounds and clean then. and they can look clean but inside all the wires can be dirty. i had this problem on my.................. honda lol. what I had to do was replace my ground cable then it worked great again.
pb-king07 is offline  
post #3 of 4 Old 07-03-2009, 10:21 AM
WRXtuners Member
 
Kyole's Avatar
 
Join Date: Feb 2009
Location: Ohio
Posts: 76
Images: 3
Kyole is an unknown
check and make sure the connector is plugged in all the way also..
Kyole is offline  
post #4 of 4 Old 07-09-2009, 11:20 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2009
Location: New York
Posts: 110
Images: 3
slo2sixty is an unknown
All the grounds look good, terminals everything. i think im gonna head down to a buddys shop and test the alt. Hope i dont need one i hade to get a tire for my bike ugh 200 dollars later she rides again

02 WRX Now STG 3
92 Ninja 600
Quit crying and be happy. could be driving a mustang - Jujutsuka
slo2sixty is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome