Air leak? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-31-2006, 03:33 PM Thread Starter
WRXtuners Member
 
insanity500's Avatar
 
Join Date: Aug 2005
Location: Maryland
Posts: 213
Images: 6
insanity500 is an unknown
Send a message via AIM to insanity500
Air leak?

For a while I have been experiencing a whooshing sound when accelerating (Always after the turbo kicks in) It is not the normal turbo whine, I can hear that in addition to this sound. It kind of sounds like the a/c on full blast, but all air/heat is completely off. Would an air leak sound this loud? It is very noticeable, not just a faint noise.
I have a HKS SSQV installed, but this noise started a while after I installed it. (Though I am considering putting the stock back on anyway)
It kind of feels like there is a power loss as well, but that could just be in my head
Any ideas?

*Edit* - I don't have a boost gauge, so at the moment I can't tell if I am losing boost. I can't check anything on the dashboard (UTEC) because my laptop was stolen

-Chris
insanity500 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-03-2006, 08:24 PM
WRXtuners Member
 
nick4592's Avatar
 
Join Date: Sep 2005
Location: Colorado
Posts: 1,030
Images: 9
nick4592 is more helpful than not
Send a message via AIM to nick4592 Send a message via MSN to nick4592 Send a message via Yahoo to nick4592
try to tighten you BOV....additionally check your wastegate...it could be getting stuck slightly open

"Life's a bowl of punch so go ahead and Spike it!" -311
nick4592 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On