Air intake problem - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-26-2004, 03:25 PM
WRXtuners Member
 
Join Date: Apr 2003
Location: NC
Posts: 25
Speedracer is an unknown
Send a message via AIM to Speedracer Send a message via Yahoo to Speedracer
Air intake problem

Okay well you see i have a cold air intake. But i took the bottom half off and just left the top half but that threw the check engine light. Went and had it obd and it was running lean. Now the easy solution would be just put it back the way it was. But seeing how the light was thrown, and it is running lean then it must be getting more air thus needing more gas. Thus more HP anyone got any suggestions?
Speedracer is offline  
Sponsored Links
Advertisement
 
#2 Old 06-08-2004, 06:58 PM
WRXtuners Member
 
Join Date: Dec 2003
Location: New York
Posts: 23
TRTrex is an unknown
Is the intake sticking out into the cone? if so there 's your CEL...happen to me. I pushed the filter to far into the intake and got a CEL in 5 min.
TRTrex is offline  
#3 Old 06-08-2004, 07:00 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
No, the problem is the intake itself. The shape of it alters the path of the air crossing the MAF sensor. That is what is triggering the CEL. Put the stock intake back on and you will be fine.
Cosmo is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On