acceleration issue - Page 2 - Subaru WRX Forum
 4Likes
Reply
 
LinkBack Thread Tools Display Modes
#16 Old 02-28-2014, 12:36 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Quote:
Originally Posted by Aggro Crag View Post
that's great that said company makes them, but where do you purchase it IN JAPAN?!?!
Anyway, I finally found some on amazon. the big issue was it isn't referred to as a Mass Airflow Sensor in japanese, just an Airflow Sensor.
The stuff I bought is made by Kure. I didn't see it at any auto parts stores though.
I know on the back of the CRC cleaners here it states what NOT to use it on. Check that too.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Sponsored Links
Advertisement
 
#17 Old 03-01-2014, 07:10 AM
WRXtuners Member
 
Sub14WRX's Avatar
 
Join Date: Dec 2013
Location: New Jersey
Posts: 80
Sub14WRX is more helpful than not
Garage
Quote:
Originally Posted by thekamikaze kid View Post
so u guys think its some type of leak? I just had the car in for a full tune up, and it didnt help at all. I would think my mech would have checked all that stuff. it ran a little better the first week or so. i was running a perrin sri without a tune for a while, (it did the same thing before and after the intake swap) and swapped in a cobb intake that supposedly doesnt tneed a tune and i figured this would help but didnt either. !Cry!
Im pretty sure you need a tune with the Cobb Intake...
G0ATLIF3 likes this.
Sub14WRX is offline  
#18 Old 03-01-2014, 12:37 PM
WRXtuners Member
 
thekamikaze kid's Avatar
 
Join Date: Jun 2012
Location: New York
Posts: 525
thekamikaze kid is a helpful contributing member
for my year (03) the cobb intake doesnt need a tune. i think the 08's and up need tunes for the cobb intake. all maps for my year are for both the cobb and stock intake.
thekamikaze kid is offline  
#19 Old 03-02-2014, 07:29 PM
WRXtuners Member
 
Sub14WRX's Avatar
 
Join Date: Dec 2013
Location: New Jersey
Posts: 80
Sub14WRX is more helpful than not
Garage
Cobb does have tunes for the 03 thats all im saying, i would try it out see if it helps do you have AP
Sub14WRX is offline  
#20 Old 03-02-2014, 07:37 PM
WRXtuners Member
 
Join Date: Mar 2014
Posts: 7
wrxguy217 is an unknown
possibly coil packs, check maf sensor, clean it if needed, check plugs also, go a step colder and use iridium, dont use platinum, and also dont trust stock gap, tighten up the gap a little bit
wrxguy217 is offline  
#21 Old 03-02-2014, 07:38 PM
WRXtuners Member
 
thekamikaze kid's Avatar
 
Join Date: Jun 2012
Location: New York
Posts: 525
thekamikaze kid is a helpful contributing member
I'm ccobbstage1 right now. The map I have installed is for both the stock and Cobb intake and don't believe they make special maps for just the Cobb intake. If you know of a special map post me up the link!
Aggro Crag likes this.
thekamikaze kid is offline  
#22 Old 03-03-2014, 07:10 AM
WRXtuners Member
 
Aggro Crag's Avatar
 
Join Date: Apr 2013
Location: Asia
Posts: 30
Images: 2
Aggro Crag is an unknown
Garage
Send a message via Skype™ to Aggro Crag
Quote:
Originally Posted by wrxguy217 View Post
possibly coil packs, check maf sensor, clean it if needed, check plugs also, go a step colder and use iridium, dont use platinum, and also dont trust stock gap, tighten up the gap a little bit
so you're telling me it's broken, and there may be something wrong?

boo-key bear likes this.

ahhh yeah
Aggro Crag is offline  
#23 Old 03-03-2014, 04:57 PM
WRXtuners Member
 
G0ATLIF3's Avatar
 
Join Date: Feb 2014
Location: Alberta, Canada
Posts: 19
G0ATLIF3 is an unknown
Quote:
Originally Posted by thekamikaze kid View Post
I'm ccobbstage1 right now. The map I have installed is for both the stock and Cobb intake and don't believe they make special maps for just the Cobb intake. If you know of a special map post me up the link!
There are different maps for SF intake, one has +SF and one does not. FYI.

http://www.cobbtuning.com/Accessport...x/WRX-Map-Grid

10 WRX HATCH PEARL WHITE

Last edited by G0ATLIF3; 03-03-2014 at 05:11 PM. Reason: Added URL
G0ATLIF3 is offline  
#24 Old 03-03-2014, 05:14 PM
WRXtuners Member
 
thekamikaze kid's Avatar
 
Join Date: Jun 2012
Location: New York
Posts: 525
thekamikaze kid is a helpful contributing member
they are the same maps, they are just labeled as one for the other models. if yiou look up top of both catagories it says "2002-2003 Subaru WRX - Stock or COBB SF Intake". you wont find the +sf in either link. thanks though! like i said though at the 08+ models they have the option for the + sf intake
thekamikaze kid is offline  
#25 Old 03-03-2014, 05:20 PM
WRXtuners Member
 
G0ATLIF3's Avatar
 
Join Date: Feb 2014
Location: Alberta, Canada
Posts: 19
G0ATLIF3 is an unknown
Quote:
Originally Posted by thekamikaze kid View Post
they are the same maps, they are just labeled as one for the other models. if yiou look up top of both catagories it says "2002-2003 Subaru WRX - Stock or COBB SF Intake". you wont find the +sf in either link. thanks though! like i said though at the 08+ models they have the option for the + sf intake
Aha! I stand corrected. Thanks for the info.

10 WRX HATCH PEARL WHITE
G0ATLIF3 is offline  
#26 Old 03-12-2014, 03:33 AM
WRXtuners Member
 
Aggro Crag's Avatar
 
Join Date: Apr 2013
Location: Asia
Posts: 30
Images: 2
Aggro Crag is an unknown
Garage
Send a message via Skype™ to Aggro Crag
so I cleaned my MAF, and it got worse.
the check engine light is on now. it wasn't before.
I realized today that I didn't disconnect the battery when I took out and cleaned the MAF.
I just disconnected the battery and the check engine light is still on.
Aggro Crag is offline  
#27 Old 03-12-2014, 11:53 AM
WRXtuners Member
 
Bubba James's Avatar
 
Join Date: Jan 2014
Location: Tennessee
Posts: 107
Bubba James is an unknown
Quote:
Originally Posted by Aggro Crag View Post
so I cleaned my MAF, and it got worse.
the check engine light is on now. it wasn't before.
I realized today that I didn't disconnect the battery when I took out and cleaned the MAF.
I just disconnected the battery and the check engine light is still on.
What's the code? Did you break the filament wires by accident when attempting to clean the MAF? They're very small and fragile and are seated kind if up in the housing.
Bubba James is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On