Problem Diagnosis - Subaru WRX Forum
Post New Thread
Threads in Forum : Problem Diagnosis Forum Tools Search this Forum
  Thread / Thread Starter Last Post Replies Reverse Sort Order Views
 
Sticky Thread Read me: MISS fire ..HELP PLEASE (Multi-page thread 1 2 3 4 )
02-11-2015 10:58 AM
by AllExtinct Last Post
58 19,710
 
Sticky Thread Read me: Code list for your pleasure! (Multi-page thread 1 2 )
09-08-2014 10:07 PM
by boo-key Last Post
21 16,587
 
Sticky Thread Read me: ATTN everyone! please read first...
01-24-2009 10:18 AM
by dumdum Last Post
2 6,781
 
Sticky Thread Read me: Subaru OBD2 Code Key
01-27-2013 06:37 PM
by ashahrila Last Post
1 14,119
 
03-15-2005 09:51 PM
by Ludachris Last Post
0 4,253
 
Ford GT Interior Inspires Creativity at Milan Design Show
Ford Motor Company
Sponsored Post
by Ford Motor Company Go to last post
- -
 
06-26-2009 10:07 PM
by newtothegame Last Post
86 3,019
 
05-31-2008 11:04 AM
by baller_v24 Last Post
68 4,365
 
1 Attachment(s) Misfire codes (Multi-page thread 1 2 3 4 5 )
06-13-2012 10:07 PM
by jakewest209 Last Post
66 13,992
 
Low boost for no reason (Multi-page thread 1 2 3 4 5 )
11-12-2013 06:05 PM
by Fidrat Last Post
60 5,714
 
Engine not starting (Multi-page thread 1 2 3 4 )
08-07-2009 02:40 AM
by lptrick7 Last Post
54 8,988
 
new bpv (Multi-page thread 1 2 3 4 )
11-15-2013 04:32 PM
by thekamikaze kid Last Post
52 2,465
 
1 Attachment(s) PO224 wastegate (Multi-page thread 1 2 3 4 )
12-08-2013 06:20 PM
by Nathan21 Last Post
50 3,243
 
Sat for years and now won't run (Multi-page thread 1 2 3 4 )
10-04-2011 07:11 PM
by Zig E. Last Post
49 3,154
 
Mystery, deal stumping scooby dilema (Multi-page thread 1 2 3 4 )
01-22-2008 10:03 PM
by burkej62 Last Post
46 2,313
 
03 wrx cel on for awhile (Multi-page thread 1 2 3 4 )
04-09-2010 05:40 PM
by sivart08 Last Post
45 5,247
 
10-18-2013 05:03 PM
by mpinto19k Last Post
45 3,216
 
Engine GonE???? (Multi-page thread 1 2 3 )
09-08-2011 08:05 AM
by GamerzBM Last Post
44 2,821
 
03-30-2009 04:12 PM
by Chase Last Post
43 5,845
 
Boost Pressure Problem (Multi-page thread 1 2 3 )
02-16-2008 01:26 PM
by SWFL Scooby Last Post
41 2,988
 
Occasional boost = dying turbo? (Multi-page thread 1 2 3 )
04-29-2012 09:14 AM
by man show Last Post
40 6,414
 
12-07-2013 02:52 PM
by STravis Last Post
40 2,892
 
Only boosting 9.6psi?!?! (Multi-page thread 1 2 3 )
05-09-2007 07:15 AM
by dumdum Last Post
38 3,142
 
06 wrx making weird noise (Multi-page thread 1 2 3 )
09-20-2011 02:34 PM
by turmic Last Post
37 7,360
 
2004 WRX Code P0304 (Multi-page thread 1 2 3 )
01-05-2010 12:47 PM
by RUUP4IT101 Last Post
36 8,728
 
my car wont start!! (Multi-page thread 1 2 3 )
07-19-2007 10:46 AM
by RedWReX Last Post
35 2,539
 
Turbo and/or wastegate probs (Multi-page thread 1 2 3 )
04-09-2009 10:22 PM
by jed344 Last Post
35 2,052
 
Car will not start (Multi-page thread 1 2 3 )
06-06-2007 02:12 AM
by Blue07Rex Last Post
34 2,135
 
11-20-2011 05:11 PM
by Dollarosa Last Post
34 15,384
 
need help (Multi-page thread 1 2 3 )
05-28-2007 01:35 PM
by dumdum Last Post
34 1,626
Question
05-29-2009 10:12 PM
by cody Last Post
34 13,457
 
03 wrx boost issue (Multi-page thread 1 2 3 )
10-26-2012 11:27 AM
by BoostinChick Last Post
34 2,714
Question
02-19-2014 06:26 PM
by Brockton Last Post
34 8,500
 
winter grip problems (Multi-page thread 1 2 3 )
02-10-2009 11:04 AM
by turmic Last Post
32 1,883
 
06-01-2009 08:03 PM
by pb-king07 Last Post
32 4,357
 
2 Attachment(s) Go BOV Yourself!!! (Multi-page thread 1 2 3 )
04-23-2014 07:08 PM
by BLAZE2099 Last Post
32 4,445
 
10 Psi!!!??? (Multi-page thread 1 2 3 )
07-28-2004 04:46 PM
by tescrex Last Post
31 3,499
 
9 Attachment(s) Car dies in the rain (Multi-page thread 1 2 3 )
01-11-2006 05:44 PM
by eighth08 Last Post
31 2,799
Exclamation
Bad Shaking... (Multi-page thread 1 2 3 )
09-04-2007 08:21 PM
by LiL Shoaf Last Post
31 3,014
Exclamation
ROMraider guys, come hither! (Multi-page thread 1 2 3 )
12-22-2008 01:38 PM
by 03 CrazyTaxi Last Post
31 4,173
 
08 STi not boosting. (Multi-page thread 1 2 3 )
06-29-2011 10:19 PM
by turmic Last Post
31 6,245
Question
Misfire and shuttering acceleration (Multi-page thread 1 2 3 )
03-14-2013 03:49 PM
by Haw1es Last Post
31 8,609
 
3 Attachment(s) Low boost?? (Multi-page thread 1 2 3 )
06-04-2007 04:10 PM
by fast_dak Last Post
30 2,421
 
boost problems no power (Multi-page thread 1 2 3 )
04-07-2008 10:24 PM
by baller_v24 Last Post
30 5,181
 
help i'm so screwed! (Multi-page thread 1 2 3 )
06-10-2008 08:26 AM
by Wagondude Last Post
30 1,777
Cool
4k rpm's and up feels like MAF (Multi-page thread 1 2 )
07-21-2008 04:30 PM
by dubrex2002 Last Post
29 6,336
 
Leaking BOV??? (Multi-page thread 1 2 )
12-08-2008 12:51 PM
by TurboRyan Last Post
28 7,468
 
06-16-2009 06:59 PM
by newtothegame Last Post
28 3,037
Exclamation
3 Attachment(s) So Pissed (Multi-page thread 1 2 )
12-29-2008 12:37 PM
by Danielson Last Post
28 1,989
Question
Stage 2 2007 WRX running very rough (Multi-page thread 1 2 )
12-11-2009 05:01 AM
by pzr2874 Last Post
28 4,677
 
Over boosted again (Multi-page thread 1 2 )
02-03-2010 07:58 AM
by mfarnham Last Post
28 1,647
 
knocking noise... (Multi-page thread 1 2 )
07-25-2006 05:56 PM
by imbeterthanu Last Post
27 2,176
  - - -
 
I hit 1.54 bar now (Multi-page thread 1 2 )
08-05-2006 12:42 PM
by six3jag Last Post
27 1,405
 
Flashing CEL help...? (Multi-page thread 1 2 )
04-24-2009 08:17 PM
by Cooper Last Post
27 5,353
 
09-02-2012 10:33 PM
by man show Last Post
27 2,496
Post New Thread

Display Options Currently Active Users Moderators
Showing threads 1 to 50 of 2403 39 (0 members & 39 guests) Moderators : 4
 
Forum Tools Search this Forum
Mark This Forum Read
View Parent Forum
Search this Forum :

Advanced Search

New posts New posts More than 15 replies or 100 views Hot thread with new posts
No new posts No new posts No new posts Hot thread with no new posts
Closed Thread Thread is closed  

 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome