2011 WRX throwing P0301, 0303, 0304 - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 04-20-2013, 08:51 PM
WRXtuners Member
 
ryand.white's Avatar
 
Join Date: Jun 2010
Location: New Hampshire
Posts: 6
ryand.white is an unknown
2011 WRX throwing P0301, 0303, 0304

Hey guys,

I did some searching on here but I was only finding info on '02 and '05 WRX issues. I was leaving the gym today and started up the car, looked down at my phone to get some music going and looked back up to see my CEL, Traction Control, and Cruise control light going nuts. I shut it off and started it back up, but it was still there. A few months ago in the bitter cold in NH (0 degrees) , I had a CEL and TCS light come on when I first started it in the morning. I let it warm up and shut it off and restarted and it came up normal after that. That was the reason I tried this today as well, but no such luck on whatever it was clearing. I drove straight to Auto Zone to get the codes and I got a P 0301, 0303, and 0304. Is it common for all three to crap out at once?
It's a 2011 WRX with an Injen CAI and that's it. Everything else is stock. I will say, I just had the 30k maintenance done on it 2 months ago at a dealership back home. However home is NH and I'm in the middle of nowhere TX (San Angelo) for some military training. I looked around for a Subaru dealer and found out the closest one is over 100 miles away. Of course SOA customer service was closed for the day by the time I got home, so I couldn't ask about finding an authorized maintainer locally. Now I don't know if I'm going to have to limp it over 100 miles to find out if its covered and be out a tank of gas there and back, plus the cost of some coil packs, or what.
Do any of you guys have any thoughts on a way forward for this? Have you heard of this happening before? Is there an off chance that anyone on here knows of an authorized Subaru maintenance place that will do warranty work (if its covered) near here in TX?
Anything you can give me might put me in a better mood, as of right now I'm not a happy person...I have a sputtering and rough idling 2011 sadly sitting in front of my apartment...
ryand.white is offline  
Sponsored Links
Advertisement
 
#2 Old 04-20-2013, 11:41 PM
WRXtuners Member
 
RickyTurbo11's Avatar
 
Join Date: Jan 2013
Location: Massachusetts
Posts: 71
RickyTurbo11 is an unknown
Dont know what those codes are but if you have an intake and havent tuned for it youll get some serious issues with your car
RickyTurbo11 is offline  
#3 Old 04-21-2013, 12:04 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Any dealer in TX should be able to look at it

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#4 Old 04-21-2013, 05:11 PM
WRXtuners Member
 
ryand.white's Avatar
 
Join Date: Jun 2010
Location: New Hampshire
Posts: 6
ryand.white is an unknown
That sucks...so I should prob invest in the Cobb Access Port sooner than later upon what I'm assuming is the replacement of my coil packs. Well this is the first and biggest learning lesson in the difference between N/A and turbo. This being my first turbo, I didn't know I'd need it tuned just for an intake...guess I should've cruised the forums prior to doing a thing to the car.
Thanks guys!

-Ryan
ryand.white is offline  
#5 Old 04-21-2013, 05:35 PM
WRXtuners Member
 
Brockton's Avatar
 
Join Date: Mar 2013
Location: Illinois
Posts: 372
Brockton is a helpful contributing member
Garage
Its the way these cars are tuned from the factory, not so much that its a turbo'd car
Brockton is offline  
#6 Old 04-21-2013, 06:11 PM
Premium Member
 
the RIOT act's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 1,136
the RIOT act is more helpful than not
Garage
An AP isn't gonna solve that problem for you man, and the intake is most def the root of your problem. The Injen CAI is the worst offender of changing pipe diameter and bends from the OE system also. You're gonna need to take that intake off till you can get a protune. Anything Cobb's AP has to offer isn't going to help, as I recently was informed myself that they in no way adjust for intakes. Either sell the CAI or take it off till you have money for a DP and hit stage 2 with an OS protune.

That intake been on there for the whole 30k?


Sent from AutoGuide.com App

Brandon - 13' SWP WRX Sedan

Last edited by the RIOT act; 04-22-2013 at 05:53 AM.
the RIOT act is offline  
#7 Old 04-22-2013, 12:59 AM
WRXtuners Member
 
ryand.white's Avatar
 
Join Date: Jun 2010
Location: New Hampshire
Posts: 6
ryand.white is an unknown
I've had the intake on for probably 15k of the 30k on the car. I've had no issues really until Saturday afternoon, when cylinders 1,3, and 4 started misfiring. Unfortunately, like I said, I'm in TX...so the stock intake parts are back up in NH somewhere in my storage unit. I know this might sound a little ridiculous, but is there an aftermarket intake I can put on in the meantime that won't mess with the car the way the Injen does? Should I go short ram instead?
I've got to call SOA tomorrow anyway and see if there is anything local to San Angelo where they'll take a look at in case it might be covered. Although, I don't tend to have that type of luck. I appreciate you guys helping me out. I wish I had the money to go all out and get everything needed for a Stage 2 tune. I'll check back tomorrow and see what SOA or a mechanic says. I may have to order another stock set up in the meantime.
ryand.white is offline  
#8 Old 04-22-2013, 05:41 AM
Premium Member
 
the RIOT act's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 1,136
the RIOT act is more helpful than not
Garage
Some of the others may chime in about an intake that'll cause "less" problems, but no matter which one the 3G Rex's are all very problematic with intakes. I'm sure either Cobb or SPT would give you "less" problems but no matter what without a tune you're gonna be running lean.

I'm honestly surprised you never had a problem till now with your dashboard turning into a Christmas tree. I put my Injen CAI in to test the tone/sound level gains before my DP and stage 2 introduction, only drove it around the block a few times keeping it under 4k, and got all the same problems you're having right away. I had to go to Advanced Auto and have them shut off my lights before going back home to continue my DP install. Even babying it the 20 miles to my tuner set them all off again.

And the reason I asked how long the intake has been on untuned is because at this point (15k) it probably HAS fouled out your plugs. You're plugs with tell you the story. They should be light brownish when removed. If its more whitish in color that's always a good indication of "running lean" damage.

But I'd honestly say the plugs and intake are your problem not coil packs...or at least start there as its cheaper than coil packs. Someone more knowledgable with plugs/coils can verify that the intake hasn't itself damaged the coils, but I don't believe running lean can damage them. Either way I'd get the intake off, change your plugs, and clear the codes. If the rough idle and misfire is still a problem THEN start replacing coil packs. But at this point (15k) your plugs are without a doubt wasted!


Sent from AutoGuide.com App

Brandon - 13' SWP WRX Sedan
the RIOT act is offline  
#9 Old 04-22-2013, 05:50 AM
Premium Member
 
the RIOT act's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 1,136
the RIOT act is more helpful than not
Garage
^^this guy is long winded^^ !!


Sent from AutoGuide.com App

Brandon - 13' SWP WRX Sedan
the RIOT act is offline  
#10 Old 04-22-2013, 05:58 AM
Premium Member
 
the RIOT act's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 1,136
the RIOT act is more helpful than not
Garage
But I'd try an get someone from home to ship you your stock intake setup before any trip to the dealer is considered, cause as soon as they see the CAI the questions are gonna start rolling out! Is it tuned would be the first one...to which you should say no! But if they do see the CAI and you do say no its not tuned that's even more of a warranty nightmare for you in store. Best of luck OP


Sent from AutoGuide.com App

Brandon - 13' SWP WRX Sedan
the RIOT act is offline  
#11 Old 04-22-2013, 06:11 AM
WRXtuners Member
 
NeverSummer's Avatar
 
Join Date: Feb 2013
Location: New York
Posts: 342
NeverSummer is more helpful than not
Def dont go to the dealer w any CAI on. I would avoid going there til you have the stock stuff on!


Sent from AutoGuide.com App
NeverSummer is offline  
#12 Old 04-22-2013, 12:03 PM
WRXtuners Member
 
ryand.white's Avatar
 
Join Date: Jun 2010
Location: New Hampshire
Posts: 6
ryand.white is an unknown
Yeah I figured I'd start small and see what I can do. I've never messed with the Subaru engine. I'm used to the Honda and Nissan engines that I used to have, but I'll just pick up a manual or dig around on here to figure out the other stuff. I'm going to work on getting my stock setup, or look around on the forums for one that I can get cheap. I'll dig into the plugs sometime this week and check them out.
I put some Seafoam in the car as supposedly the gas stations here in San Angelo are notorious for bad gas, so I figured a little cleaner wouldn't hurt. I reset the ECU and let it run at idle for a few mins and have had no issues yet. I'm going to take it for a drive in a bit. I appreciate all of the help guys. I'll be checking in on here before I do anything else to my baby haha.
ryand.white is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On