2010 WRX MT Oil - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 01-07-2010, 07:53 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2010
Location: Alabama
Posts: 13
cgravat is an unknown
2010 WRX MT Oil

Hi all,

Bought my 2010 WRX about 2 weeks ago with roughly 65 miles on it. It now has about 1,200 miles on it.

Today I checked all of my fluids. Everything was normal, except the MT Oil (I guess it's also the front diff oil). There was hardly any level at all on the dip stick. It was just under the L mark. Seems odd for a brand new car.

Conditions:

-It's been really cold here in Huntsville, AL the past week ( about 28Deg Fahrenheit).
-I've driven it hard probably 4 or 5 times, always once it's up to temperature....
-There is the smell of burning coming from under the hood.... It's not overpowering, except for once when I drove it quite hard from a dead stop (This was yesterday, so it was past the 1,000 mile mark). From what I've read, it's the factory grease and coatings burning off, most likely.

I know I should probably take it to the dealership and have them check everything out. But, the dealership here has like a one week waiting list for service (wtf).

Anyone ever seen anything like this before?
Suggestions?

Thanks so much

- Chris
cgravat is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 01-07-2010, 11:25 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
1. Take it back to the dealer and have them top it off for you
2. You could fill it with your own fluid i always use RedLine ShockProof gear oil in mine
3. I wouldn't be beating on that car till you get some more miles on it IMO

2003 WRX Hybrid build,

Brian
VD5505 is offline  
post #3 of 10 Old 01-07-2010, 11:55 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2010
Location: Alabama
Posts: 13
cgravat is an unknown
Thanks for the reply....

As stated in the original post, the dealer has a 1 week wait until they will be able to do ANYTHING.

I am fully capable of topping off the MT Oil, but in the owners manual it specifically says not to mix brands. So, that means I need to get exactly the same thing that came in it. I would assume subaru brand, but what weight? And even though I can do this on my own, I'd still like to know if this has ever been heard of before. Seems extremely odd.

While I appreciate that you would wait longer to "beat on it", I'd hardly say I'm beating on it. I drive the car very conservative, aside from the very few times I've gotten on it. All of those times have been after 1,000 miles.
cgravat is offline  
post #4 of 10 Old 01-08-2010, 01:13 AM
WRXtuners Member
 
Join Date: Jan 2010
Location: Colorado
Posts: 37
Images: 2
pearlwhite10 is an unknown
I just got a new one at about the same time, and all my levels were nice and high... of course, I only have about 600 miles...
I had that same oil smell coming out of my car as well, but only for about the first week or so...
pearlwhite10 is offline  
post #5 of 10 Old 01-08-2010, 01:31 AM Thread Starter
WRXtuners Member
 
Join Date: Jan 2010
Location: Alabama
Posts: 13
cgravat is an unknown
Yeah... I smelled it very faintly for the first couple hundred miles... Then, once I got it over 1,000 miles, getting on it those couple times, especially that one time, I'd smell it more... The smell isn't in the cabin, just if I sniff by the hood scoop or pop the hood.

I won't lie, the smell concerns me somewhat. But I've read a few postings stating that smells like burning brakes or clutch like burning smells are normal for sometimes a few thousand miles... Please, someone chime in, if this is inaccurate.

The main thing that concerns me is this transmission oil level issue.... I paid waaaay too much for this car to have ANY sort of issue...
cgravat is offline  
post #6 of 10 Old 01-08-2010, 11:22 AM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
First off congrats on a sweet ride.. Second, 28 degress is not really cold lol (maybe for you). Third, the burning smell is probably the clutch, when you got on it did you let off kinda slow? If so, you probably just glazed it a bit and slightly burned it. Don't let off the clutch too slow if you're really gassing it. At the same time, you don't want to just dump the clutch. Fine line. I gave my clutch a good glazing and it smelled pretty bad in the engine bay and even in the cabin.

Fourthly, when are you checking the fluid level? Not sure about the wrx but usually you want to have the car running for a good twenty miles (not minutes, car needs to be moving) before you check it so the fluid is nice and warm. Then, leave it running and check the level while in neutral. The tranny doesn't consume oil, so if nothings leaking you should be fine, unless they didn't put enough in it at the factory.

-Chris
RcrsWetDream is offline  
post #7 of 10 Old 01-08-2010, 01:12 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2010
Location: Alabama
Posts: 13
cgravat is an unknown
Thanks!.... I love the wrx. Partially because you don't see a lot of them on the road, but also because it's so much fun to drive.

You're definitely right about the clutch burn when I did the hard launch... I'm sure that's what made the smell so intense. But, when I drive it normally I can smell a very faint smell of burning if I stick my nose in front of the hood scoop, or under the hood. But as stated before it's probably just breaking in smells.

I've been driving manual transmissions for about 10 years. And I have to say the this Subie is quite challenging to get the hang of shifting silky smooth.

Went up to the dealer and I spoke with a different person than last time. He called the head mechanic, and he checked my mt oil right away. It came up to full level! I suppose I was rubbing it against something as I was pulling it out. Yeah, yeah, I'm a noob.

Man I love this car though!
cgravat is offline  
post #8 of 10 Old 01-08-2010, 03:39 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
The smell you are prob smelling is just all the light oils that may be left on the engine from when they built the car every car is going to have a different smell when they are new, every engine i have built for my cars and other cars will have that faint smell to them for a little while. Just watch your fluid levels and you should be fine.

2003 WRX Hybrid build,

Brian
VD5505 is offline  
post #9 of 10 Old 01-08-2010, 03:40 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
The smell you are prob smelling is just all the light oils that may be left on the engine from when they built the car every car is going to have a different smell when they are new, every engine i have built for my cars and other cars will have that faint smell to them for a little while. Just watch your fluid levels and you should be fine.

2003 WRX Hybrid build,

Brian
VD5505 is offline  
post #10 of 10 Old 01-08-2010, 05:35 PM
WRXtuners Member
 
Join Date: Sep 2009
Location: Michigan
Posts: 2,158
RcrsWetDream is known to be trustworthy and helpful RcrsWetDream is known to be trustworthy and helpful
Quote:
Originally Posted by cgravat View Post
Thanks!.... I love the wrx. Partially because you don't see a lot of them on the road, but also because it's so much fun to drive.
Come to Utah sometime... Moved here from Detroit, where I went all of the week of xmas this year without seeing a WRX. Now I would say I see 7-10 WRX on average a day, although very few 09's.

-Chris
RcrsWetDream is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On