Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   2008 STi Starts Normally and Then Immediately Dies (http://www.wrxtuners.com/forums/f72/2008-sti-starts-normally-then-immediately-dies-44762/)

f4ight 02-09-2014 10:57 AM

2008 STi Starts Normally and Then Immediately Dies
 
Out of the blue my 2008 STi will start normally, shoot for 1500 RPM, and then immediately die. I drove the car the night before and everything was fine and went to start it in the morning and it won't stay lit. Nothing appears to be wet under the hood but we did have light rain that evening.

Video with my foot off the pedal
[ame=http://www.youtube.com/watch?v=hiGEx-0xGPo]2008 Subaru STi Starts and then Dies #1 - YouTube[/ame]

Video with my foot on the pedal ~10% (same thing happens even with a jump start)
[ame=http://www.youtube.com/watch?v=qOrX8Clss88]2008 Subaru STi Starts and then Dies #2 - YouTube[/ame]

Under hood picture with the location of where I measured fuel pressure marked in yellow
[url]https://dl.dropboxusercontent.com/u/5085/IMG_20140209_081338.jpg[/url]

The car is a 2008 STi with 19,000 miles, GT3076R turbo, custom up/down pipes, FMIC, Abaco 85mm MAF, DeatschWerks 850cc fuel injectors, Walbro GSS342 fuel pump, and Crawford air to oil separator kit. It has run strong since I bought the car without any starting problems. For about a month I have had a random and mildly rough idle that I attributed to plugs but hadn't gotten around to changing them.

Things I have done and then tried to restart it:
Jump starting it with another car since the battery was low
Resetting the ECU (checked for codes first)
Uninstalling the Access Port reverting back to stock calibration
Reinstalling the calibration
Disconnecting the battery
Using my two other set of keys
Disconnected the MAF
Reconnected the MAF
Checked fuel pressure and stays at ~45 psi (see pic for hose I tapped into)
Replaced spark plugs with new NGK Iridiums
Checked for obvious loose parts or split plumbing

There was no change whatsoever even when putting it back to the stock calibration which is weird because it has a different MAF and injectors.

Things I have monitored via Access Port:
MAF, starts in the dirt and goes up after starting
MAP, starts at baro and goes down after starting
Crank SW: starts at 0 and goes to 1 after starting
Cam SW: starts at 0 and goes to 1 after starting
Intake temp: close to ambient
Coolant temp: close to ambient
Inj PW: starts low, goes up after starting
Calculated load: starts low, goes up after starting (0.4 g/rev)
Timing: Within normal range
There are no codes stored. The only code that came in was after I disconnected the MAF and received a intake temp code.

Nothing seems out of the ordinary but the thing just won't stay lit. It is almost acting as if the ECU is shutting it down after a prescribed amount of time because of how repeatable it is. I have now tried to start the car a 100 or so times and it does the same thing every time. It also seems like it has a fixed amount of fuel and timing it will provide until the crank and the cam are synchronized and then it falls on its face.

Ideas, thoughts, magic? Thanks in advance.

f4ight 02-09-2014 07:55 PM

[SIZE="7"]FIXED![/SIZE]

Ok, temporarily fixed. Un-####ing-believable that a single resistor on an aftermarket MAF can stop a car from running.

Pulled the MAF just to make sure the connector was clean and to spray down the elements while I was there. Looked inside to see half of a 5.1 ohm resistor hanging by one pad. No idea how it got hot enough to melt the solder and move off the pad or how half of it broke and fell into the air filter. Total jimmy-rigged two 2 ohm resistors in series with another two in parallel to kinda make 5 ohms, soldered it in and it started and ran. For giggles and shits I pulled the MAF connector after the car was running and it died. No Alpha-N or Speed Density limp home whatsoever. Really lame on Subaru's part or the tuners part for not applying the corrections to the limp maps.

Before... [url]https://dl.dropboxusercontent.com/u/5085/Before.jpg[/url]

After... [url]https://dl.dropboxusercontent.com/u/5085/After.jpg[/url]

I ordered a new resistor for a buck and will put it in this week to see if there was just a freak failure of the component.
[url=http://www.digikey.com/product-detail/en/ERJ-1TRQF5R1U/PT5.1YCT-ND/613938]Invalid Request[/url]

If it dies then I am stuck with a new MAF from summit is $379. Boo.
[url]http://www.summitracing.com/parts/aao-ab-dbx85/overview/[/url]

This was a terrible way to waste the better part of 2 days.

boo-key bear 02-09-2014 09:58 PM

Thanks for sharing the fix. Its always nice when someone fills the forum in on what the problem was instead of just never returning.


All times are GMT -5. The time now is 03:41 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.