2004 WRX Code P0304 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 37 Old 12-26-2009, 11:32 PM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
2004 WRX Code P0304

I'm new to this forum and have been reading and researching alot. I currently have everything stock in my WRX the only things that aren't stock are my intake which is AEM Cold Air Intake, Blow Off Valve, Single Stage Boost Controler, and a Catback Exhaust. Well my cylinder four is misfiring and before that my cylinder one and three were misfiring. Since that happened I decided to change my spark plugs. I put in the NGK Iridium IX spark plugs. When I did this my cylinders one and three stopped misfiring and four is still misfiring as well it smells like it is running lean. I can smell fuel. I swapped my coil packs around thinking it might be them, but it still happens. As well I forgot to mention when at idle it feels like it wants to stall, and when I start to take off it seems to lag or stutter I guess you can say. I added fuel injector cleaner thinking it might help, but to no avail nothing. I was reading that some people think it my be the knock sensor. Any ideas you all could give me I would greatly appreciate. I don't want to take it to the dealerships here in Albuquerque. They are horrible and a bunch of idiots to be honest. I've had run ins with them before.
RUUP4IT101 is offline  
Sponsored Links
Advertisement
 
post #2 of 37 Old 12-27-2009, 12:09 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
GET A TUNE. You have an other than stock intake, a BOV (known to be trouble) and a BCS on the car. You desperately need a tune or the car probably wont be running here shortly.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #3 of 37 Old 12-27-2009, 12:10 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
Is there anyone out there that can give me assistance? I would greatly appreciate it.
RUUP4IT101 is offline  
post #4 of 37 Old 12-27-2009, 12:24 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
What kind of assistance are you looking for? If you have no form of engine management, or way to account for the parts that are different from stock, then that is one of your biggest problems. CAIs are notorious for fouling a subaru (turbo'd car). The BOV causes numerous issues also. And just installing another form/way (other than stock) of controlling boost and turning knobs has its drawbacks also. How long have you had that car? How long have you had these problems? Is this your first forced induction car?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #5 of 37 Old 12-27-2009, 12:44 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
I appreciate your help newtothegame. I didn't see your response before
RUUP4IT101 is offline  
post #6 of 37 Old 12-27-2009, 12:48 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
Ive had the car since 04 and its been mod'd since then with no issues this just started this week
RUUP4IT101 is offline  
post #7 of 37 Old 12-27-2009, 12:49 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Oh ok, no problem. Was just making sure you werent just shrugging off some light critcism. I mean I wasnt trying to be harsh, just letting you know that a coupe of those mods on the car arent really the best on a stock setup.

Oh ok, so basically had the car the whole time and it just now started acting up? AN you have never been tuned for the intake or anything?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #8 of 37 Old 12-27-2009, 12:56 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
No I love actually getting criticism its what makes us better. Ive been dealing with criticism in the navy for the past ten years
RUUP4IT101 is offline  
post #9 of 37 Old 12-27-2009, 01:01 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Well I know how that criticism goes with the armed forces, 9 years in the army. But why do people think its the knock sensor? Are you throwing any codes other than the cylinder 4 misfire?

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #10 of 37 Old 12-27-2009, 01:13 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
No jUst that code nothing else
RUUP4IT101 is offline  
post #11 of 37 Old 12-27-2009, 01:21 AM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
No jUst that code nothing else
RUUP4IT101 is offline  
post #12 of 37 Old 12-27-2009, 12:05 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
Man before I really jump to and conclusions here I really think you should do a compression test and or a leak down test. Try at least to do a compression test and see what your numbers are, you want them to be at least consistent with each other. Have you ever seen your Check Engine Light (CEL) flash before? What happened to me is just what you had and it turned out that my number 4 piston was cracked. The #4 cylinder generally starves for more oil than the other 3 do as well as the #3 cylinder will generally be a little hotter cause of the heat soak. I wish you the best of luck and let us know what you find out.

And i know what you mean about criticism lol, I'm also in the Navy out here in Virginia Beach, Va
VD5505 is offline  
post #13 of 37 Old 12-27-2009, 03:16 PM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
Yeah what happened is it was saying that my engine was misfiring in cylinders one and three but the CEL was on solid. So I decided to change my plugs to the NGK Iridium IX. When I did that the I reset my CEL. Well I went to take it for a test drive to see if that fixed the problem. Well when I was at idle the car seemed liked it wanted to die it was stuttering at idle as well my CEL started flashing at me and then would eventually turn solid. When I took off it lagged and didn't want to go I would have to rev the engine to get it going and to keep it from doing that. So I took it back home and figured maybe my fuel injectors are dirty so I got some cleaner and cleaned them. Well it still happened. So I decided to swap around my coil packs to see if it was maybe them. It wasn't them as I found out. Well I noticed it sounded like a knocking sound kind of. So like I said at first I was researching and heard people saying they had similiar problems and it being the knock sensor, but I do need to do a compression test and a leak down test. I'm going to tap near the knock sensor today while the engine is running to see if it is my knock sensor. The only thing that sucks is this is my only car and I work ten miles away lol. I guess I can walk but love my WRX. I appreciate all of your help.
RUUP4IT101 is offline  
post #14 of 37 Old 12-27-2009, 03:19 PM Thread Starter
WRXtuners Member
 
Join Date: Dec 2009
Location: New Mexico
Posts: 22
RUUP4IT101 is an unknown
Oh and I forgot to mention it smells like fuel like my car is running lean and the knocking noise sounds like its coming back near where the uppipe is connected to the engine.
RUUP4IT101 is offline  
post #15 of 37 Old 12-27-2009, 04:21 PM
WRXtuners Member
 
VD5505's Avatar
 
Join Date: Oct 2006
Location: Iowa
Posts: 905
Images: 6
VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful VD5505 is known to be trustworthy and helpful
Send a message via AIM to VD5505 Send a message via MSN to VD5505
Take your ECM fuse out and crank the car over and see if you can hear a difference when the engine goes through it's cycles. Then after that put your fuse back in your car then start your car, after its running unplug each coil pack one by one and see if one makes less of a difference then there you have it. It is NEVER good when your CEL flashes usually when that happens that means its to late man. But do what i said and also a compression test. Let us know bro...
VD5505 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome