2003 wagon hesitation - Page 2 - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 20 Old 04-21-2012, 12:19 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2012
Location: Colorado
Posts: 10
cobra280z is an unknown
I've had the car for about 2.5 years. I don't have a boost gauge, so I'm not sure what my boost is. I'm certain that the injectors are all working at low flow anyway, since the car runs very smoothly until i get into boost and higher RPMs in 2nd and 3rd gear. I've read that being off by small amounts in fuel pressure can make a big difference, maybe this is causing the hesitation? I've also thought about the coils being bad, but again there's no way to check them reliably without switching them out for a good set (which I don't have access to).
cobra280z is offline  
Sponsored Links
Advertisement
 
post #17 of 20 Old 04-21-2012, 09:38 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,981
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
You need to find out what boost you are hitting.... In all gears really...
I don't think it's spark, but I could be wrong.


BUMP

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #18 of 20 Old 05-02-2012, 11:12 PM Thread Starter
WRXtuners Member
 
Join Date: Apr 2012
Location: Colorado
Posts: 10
cobra280z is an unknown
Update

So, finally got a boost gauge and installed it this afternoon. Did a few runs this evening. As usual, first and second feel very strong at WOT. Saw ~11ish psi in first, about 13 in second. Third made about 13 as well at WOT, though it didn't feel as strong. There is no bucking in third at WOT. There is, however, considerable bucking/hesitation in second and third at partial throttle above about 3k rpms. The boost isn't jumping all over the place though. I guess that this hesitation at partial throttle is the next thing I need to address. Any ideas?
cobra280z is offline  
post #19 of 20 Old 05-03-2012, 06:52 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,981
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Try to clean out the injectors, worst case scenario is that you are doing routine maint.

You didn't do anything with the coils yet?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #20 of 20 Old 06-29-2012, 02:09 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2012
Location: Colorado
Posts: 10
cobra280z is an unknown
Finally figured it out- my car has a bad MAF, even though it drives normally 95% of the time. After switching with a friend, the car was perfect!
cobra280z is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome