2.0L WRX fan relay question-fans run forever. HELP - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-11-2010, 11:27 AM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
2.0L WRX fan relay question-fans run forever. HELP

My04 wrx is having an issue. I have noticed this for a while now (few weeks) The fans seem to run for a very long time. The car is not over heating at all. Most of the time the fans run for 30 sec to 1 min, but today I timed them and it ran for over 8min. Now 2 weeks ago we did the coolent, drained out old and put new in. We blurped the system a few times to get out all the bubbles. But the fans are still running for a lon time and the car does not over heat. Any ideas?? I am thinking it might be something electrical, like possibly the relays. Anyone know where these fan relays are located.

All possible opinions welcomed

Thanks WRXTuners

Ryan

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
Sponsored Links
Advertisement
 
#2 Old 05-11-2010, 12:09 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Are you saying you shut off the car but leave the key in and the fan runs eight minutes?

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
#3 Old 05-11-2010, 01:04 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
No I had the car idleing to see how long the fans stayed on. And the fans also run while I am driving the car for a long time and almost like they are programmed to not shut off

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#4 Old 05-11-2010, 01:18 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
Is your A/C on? Your fan runs continuously while your compressor is active.

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
#5 Old 05-11-2010, 01:45 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
A/C light is not lit up nor is the Defrost light

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#6 Old 05-11-2010, 01:56 PM
WRXtuners Member
 
Join Date: Apr 2008
Location: New York
Posts: 454
Images: 1
VisiX is a helpful contributing member
I'm out of ideas, seems like everything is working fine to me. If you are sitting there idling your car your fan is likely to turn/stay on since there is no natural air currents cooling the engine. I think mine will come on at long lights.

Ryan
2009 STi - Cobb Stage 2
VisiX is offline  
#7 Old 05-11-2010, 02:15 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Quote:
Originally Posted by VisiX View Post
I'm out of ideas, seems like everything is working fine to me. If you are sitting there idling your car your fan is likely to turn/stay on since there is no natural air currents cooling the engine. I think mine will come on at long lights.
Yea, but mine will come on while driving and say on for a long time while the car is moving. (Normally you would think at this time it would go off, but it continues to stay on) Thats why I think something is wrong.

Bump for more ideas

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#8 Old 05-11-2010, 06:11 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
My thread from Nasioc. Pic of HVAC controls inside aswell to confirm. Also I have BOTH fans running ont just the 1


http://forums.nasioc.com/forums/show...0#post30698250

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On