Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   08 WRX not running right, stalling, no boost. (http://www.wrxtuners.com/forums/f72/08-wrx-not-running-right-stalling-no-boost-30444/)

OBEE_Racing 03-19-2011 05:28 PM

08 WRX not running right, stalling, no boost.
 
This winter I noticed my car feeling like it was slipping...not the clutch tho, it would go, but it want feeling as much torque as usual.

Then next a throbbing, and then i believe a screetching possibly from the turbo.

I have no boost now, there no screetching.

It has been stalling out since then if im high rpm then need to slow down or stop.

When I was driving it was very sluggish. I have parked it since....its been sitting there for 3 months =( I also have been needing a oil change due to a busy travel schedule and a shitty job i hadn't been able to get one (i know bad, least i kept oil in it).

Im leaning towards the turbo bearings are gone.....but i dont want to believe it.

[COLOR="Red"]Any input from anyone who has had turbo problems, or these symptoms please comment.[/COLOR]

This car is decently modified so is it possible that the turbo was pushed to hard? My Perrin map for my Accessport is pushing 19 pounds of boost.

basco 03-19-2011 05:47 PM

I've had turbo issues but never anything that has those symptoms, almost sounds like you in a limp mode, any DTCs or flashing lights?

OBEE_Racing 03-20-2011 11:28 AM

yah actually! I forgot all about that since its been so long. all the dash lights have been on.

basco 03-20-2011 11:49 AM

go get the check engine code read then report back

OBEE_Racing 03-20-2011 01:07 PM

The last time we check it before we parked it. It gave a code that timing error with advanced timing and/or internals? I just checked again and I wont give me any codes, must have erased them.

turmic 03-21-2011 12:41 PM

Welcome back to the forums. I hope you get the problems figured out though. Did you change the oil yet?

OBEE_Racing 03-21-2011 02:10 PM

3 Attachment(s)
Hey!! Thanks, im glad to be back on.
I did find the problem. We stripped out to get the turbo out. ill post yah some pics here.

pzr2874 03-22-2011 05:41 AM

Holy crap, that took a dump. I commented on your other post on that charger you were looking at. Go on nastysock and try to locate another td04 or possibly a vf52.

basco 03-22-2011 07:55 AM

wow :eek:

OBEE_Racing 03-22-2011 10:24 AM

Basco, that was my reaction too.lol

pzr2874, im having trouble finding out what nastysock is.haha more info?? Appriciate it man!

Im really wanting to go a bit bigger, stay in budget. thinking bout a 20g. I have the supporting mods, I also got a walbro pump in my garage i havnt installed, ### it wont really do much good till i get my injectors right?

pzr2874 03-22-2011 10:38 AM

^^ I think Chris sent you some links on the other thread to some used TD's.

Injectors, pump, maybe a bigger TMIC. I think the VF52's are going very quick on NASIOC.com... Sorry, I seem to always say nastysock.... haha

OBEE_Racing 03-22-2011 10:54 AM

haha, ok i get it now. =P

Hondafan 03-22-2011 02:24 PM

Whoa. If you're changing the intercooler you can also look at used STi turbos. I might be selling mine soon as I've been looking at upgrading to a Dom 2.5XT-R. There are lots of people that upgrade their STi turbos, and the intercooler is really the only reason to stay with a LGT style turbo. That'll open up your options a little bit. STi intercoolers will sell for around $300 if you're looking for a cost effective upgrade too.

turmic 03-22-2011 03:15 PM

Holy exhaust side compressor failure. Wow!! I hope it pans out for you. Either way your budget allows you to go.

OBEE_Racing 03-22-2011 08:37 PM

lol thanks man!


All times are GMT -5. The time now is 01:51 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.