Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   08 WRX feels like its hitting a rev limiter (http://www.wrxtuners.com/forums/f72/08-wrx-feels-like-its-hitting-rev-limiter-45969/)

excruz 03-20-2014 11:30 AM

08 WRX feels like its hitting a rev limiter
 
Hey guys I bought a 08 WRX a month ago and it ran fine till a week ago. Last week it started feeling like i was hitting a rev limiter @ 4500 RPM I am new to subarus and Turbo cars so im stuck and i have no idea where to start diagnosing the problem

boo-key 03-20-2014 02:55 PM

Mods ?? When does it do it? All the time or just when wide open? Any cel's?

arcticscythe 03-20-2014 04:09 PM

I haven't run into it personally but i understand that is is not uncommon for the silicone hose that connects the inter-cooler to the intake manifold can crack or pop off all together. in that case your ECU would be adding fuel because the turbo is pulling extra air through the MAF but that compressed air would be escaping before the intake manifold.

i dont have any photos lying around but this would be the part

[url=http://www.rallysportdirect.com/Process-West-PWSH003-Replacement-Intercooler-to-Throttle-Body-Hose]Process West Replacement Intercooler to Throttle Body Hose Subaru WRX 2008-2014 / Legacy GT 2005-2009 / Forester XT 2009-2013 PWSH003 at RallySportDirect.com[/url]

hope that helps : )

excruz 03-31-2014 12:17 PM

still stuck here guys any help is more than welcomed. It has no cels no check engine light im thinking it could be the cat but theres no smell. Its starting to do it at low RPMS now at medium or WOT.

excruz 03-31-2014 12:19 PM

[quote=boo-key bear;442297]Mods ?? When does it do it? All the time or just when wide open? Any cel's?[/quote]

No cels no mods, it does it at medium to WOT 1st gear is the only gear thats not having problems

konawrx 04-01-2014 04:01 PM

i had a vac hose fail and crack that was near the turbo, cause a similar kind of thing to happen to me. it was a small crack on the underside of the hose and i couldn't figure it out for weeks.
finally went around car squeezing all hoses and finally found one above turbo that had failed. soon as i replaced it car went back to being awesome!


All times are GMT -5. The time now is 04:49 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.