06 WRX Ltd, CEL + Flashing Cruise - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 05-26-2009, 08:10 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Hawaii
Posts: 5
mzagorski is an unknown
06 WRX Ltd, CEL + Flashing Cruise

I've got a stock (for now) '06 WRX Ltd (Auto) and just had the CEL come on as well as flashing Cruise light... No mods to the car... Drove it all weekend no problems. Cleaned it on Monday. Tue morning = CEL + Cruise... Any ideas what would be up?
mzagorski is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-26-2009, 09:30 PM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
we actually just had somebody with the flashing Cruise and CEL and he had a loose gas cap...try checking that and clearing the CEL

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
post #3 of 6 Old 05-26-2009, 11:12 PM
WRXtuners Member
 
WazzuWRX's Avatar
 
Join Date: Mar 2009
Location: Washington
Posts: 12
WazzuWRX is an unknown
Your best bet is to go have the CEL code read... then go from there. You can get it done for free at most auto part stores.
WazzuWRX is offline  
post #4 of 6 Old 05-27-2009, 03:58 AM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Hawaii
Posts: 5
mzagorski is an unknown
Thanks for the replies... I checked the gas cap... Will try and get the code checked out tomorrow.
mzagorski is offline  
post #5 of 6 Old 05-27-2009, 07:17 PM
WRXtuners Member
 
srninjastar's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 338
srninjastar is more helpful than not
Send a message via AIM to srninjastar
yea i went to autozone and they gave me a free read out. replaced the gas cap made sure it clicked 3 times then unhooked the batter for a bit. connected it and the CEL was gone
srninjastar is offline  
post #6 of 6 Old 05-27-2009, 07:52 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
Please post up what the CEL code is before disconnecting the battery. If it's something serious, you'll want to leave the CEL on and take it to a dealer.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome